Intersect Tool Issues

2951
7
Jump to solution
07-28-2017 09:10 AM
TravisSwanberg
New Contributor II

Simple concept: using the intersect tool to display the intersections of inputs. In my case I am trying to show all the intersection POINTS from a LINE feature (It is a road layer and I need to find all the intersections of these roads!)

I have ran the tool several time and each time it returns an empty output. I believe it has something to do with "Work Environment" but not exactly what option to double check or change. 

Any clues would be awesome, thank you!

0 Kudos
1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

okay. A few generic steps.

try this

- Close ArcMap. 

- Open a blank ArcMap session.

- Add the Road Feature Class to Table of Content.

- Disable background Processing (Geoprocessing > Geoprocessing Options > Uncheck "Background Processing")

- Go to Geoprocessing > Environment Setting > Processing Extent. Select the Road layer as the processing extent.

- Run the Intersect tool again with the appropriate parameters.

Still the error? Consult with your local Esri Tech Tech Support.



Think Location

View solution in original post

7 Replies
JayantaPoddar
MVP Esteemed Contributor

While using Intersect—Help | ArcGIS for Desktop 

Use the "Road" Layer as input, and 

select "POINT" as the Output_Type.



Think Location
0 Kudos
TravisSwanberg
New Contributor II

I have done just that, several time. Line feature as input, point (intersection) feature as output.

Results are always "empty output".

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Could you attach a sample of the Road Feature class (zipped) for us to verify?



Think Location
0 Kudos
TravisSwanberg
New Contributor II

It is just a standard road (line) layer. I won't be able to send the data itself. I believe it has something to do with work environments and the output not matching those perimeters. 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

okay. A few generic steps.

try this

- Close ArcMap. 

- Open a blank ArcMap session.

- Add the Road Feature Class to Table of Content.

- Disable background Processing (Geoprocessing > Geoprocessing Options > Uncheck "Background Processing")

- Go to Geoprocessing > Environment Setting > Processing Extent. Select the Road layer as the processing extent.

- Run the Intersect tool again with the appropriate parameters.

Still the error? Consult with your local Esri Tech Tech Support.



Think Location
TravisSwanberg
New Contributor II

Worked perfectly that time. I just saved as layer file and added into my previous arcmap project!

Thank you.

JayantaPoddar
MVP Esteemed Contributor

Glad it worked. Could you mark the reply (that solved the issue) as "Correct Answer", so that the thread could be closed.

https://community.esri.com/docs/DOC-2159 



Think Location
0 Kudos