Geo Tagged Photo to Points Not Displaying / Coordinate Transformation help?

192
3
11-18-2013 09:08 AM
SteveBertrand
New Contributor
I have been using the GeoProcessing tools for creating points from Geo Tagged photos taken with a smartphone or GPS unit. I have used this tool many times in the past without any issues, but the photos I have been working with recently are giving me problems.  Basically, the tool will take the photos from the root folder & process them just fine, but when it creates the feature and adds it to the map, it doesn't display.  It was giving me a warning regarding coordinate system not matching that of the data frame. So, I even defined the coordinate system in the Environments before processing the photos via the tool, but still the coordinate system will not change.  It stays in GCS_WGS_1984 & I am currently using NAD_1983 (StatePlane_Indiana_West_FIPS_1302_Feet). I have tried using transformations but cannot seem to find one that works.
0 Kudos
3 Replies
markdenil
Regular Contributor II
Are you correctly defining the source projection (that applied to the photo on creation)
in the projection in your tool?

In your post, you seem to use the word 'it' to refer, at various times, to your tool, the photo, a (footprint?) feature, Arc, and the map.
That gets a bit hard to follow...
0 Kudos
SteveBertrand
New Contributor
Are you correctly defining the source projection (that applied to the photo on creation)
in the projection in your tool?

In your post, you seem to use the word 'it' to refer, at various times, to your tool, the photo, a (footprint?) feature, Arc, and the map.
That gets a bit hard to follow...


My apologies (Bad Habit) let me rephrase:

Basically, the tool will take the photos from the root folder & process them just fine, but when the tool creates the feature and adds the point feature to the map, the points won't display. Arcmap was giving me a warning regarding coordinate system not matching that of the data frame when adding the point feature to the map. I even defined the coordinate system in the Environments (within the tool options) before processing the photos via the tool, but still the coordinate system will not change. The coordinate system of the new points feature stays in GCS_WGS_1984 & I am currently using NAD_1983 (StatePlane_Indiana_West_FIPS_1302_Feet). I have tried using transformations but cannot seem to find one that works.
0 Kudos
DaleHoneycutt
Regular Contributor
The GeoTagged Photos To Points tool does not honor the Coordinate System Environment setting (see the bottom of the tool doc for environments that are honored -- the only one is Current Workspace).  You'll need to use the Project tool to project the point feature class output by the GeoTagged Photos To Points tool into another projection.

But this doesn't explain why the points won't display -- ArcMap should be able to 'project on the fly' unless it doesn't know how to do a datum shift between NAD_1983 and WGS_1984 (I haven't checked, but I believe ArcMap finds the proper datum transformation for you).

If you change the data frame to WGS_1984, do the points display?  If not, then the next question is did you edit/save your photos using Photoshop?   I've found that interjecting Photoshop into the workflow will mangle the EXIF header on your photo.
0 Kudos