'ERROR 000584: Implementation of this tool's validate is invalid'

2291
3
09-19-2018 11:46 AM
TessOldemeyer
Occasional Contributor

While trying to run the Reverse Geocode tool in ArcCatalog, I am running into a 'ERROR 000584 Implementation of this tool's validate is invalid' error. Any ideas on how to troubleshoot this?

Thanks in advance,

Tess

0 Kudos
3 Replies
shan_sarkar
Regular Contributor

Tess,

 

Please provide the following information which might be helpful to troubleshoot the issue: -

  • Version of arcgis desktop
  • License level of arcgis desktop
  • What kind of an address locator are you using? Is it an online geocode service or an address locator on your machine?
  • Can you check if the other tools give the same error or is it just the reverse geocode tool?
  • Have someone else login to your machine with their user credentials and have them check if tools throw any error for them.
  • Login in to any other machine with your credentials and see if you still get the same error?
  • Follow the steps mentioned in https://community.esri.com/docs/DOC-2121-resetting-your-arcgis-application-profile 

 

I hope this helps!

 

 

~Shan


~Shan
0 Kudos
TessOldemeyer
Occasional Contributor

Thank you for the response on this, and I apologize for the delayed response. I was trying to use ESRI's World Geocoding Service without a necessary ArcGIS Online for organizations subscription. I was wrongly assuming the service might be included in our organization's enterprise licensing. 

SeanSweeney
New Contributor III

Here's an option to try that worked for me when I got the same error from ExportMetadata_conversion If you are not already using the arcpy.env.scratchWorkspace setting, then add the following to the top of your script:

arcpy.env.scratchWorkspace = arcpy.env.scratchGDB

After many hours of trial-and-error, I stumbled on the the fact that the ExportMetadata_conversion script to wants to touch the arcpy.env.scratchWorkspace, even though the documentation says it will fall back to " the location defined by the system TEMP environment variable."  For me the default for scratchWorkspace was None.  If I set it to a folder that I have write access to then the script runs.  If I set it to a folder that I do not have write access to then the I get the 000584 error again.  Since the arcpy.env.scratchGDB is "guaranteed to exist when your script or model runs", using that seems to work for everyone in my organization that has to run the script.