Collect Values Not Adding Output to ArcMap Table of Contents

95
0
03-14-2019 09:47 AM
ChristopherMorneau
New Contributor II

For several years, I have been using a model I created in ModelBuilder to generate mailing lists from Assessor parcel data.*  The output is a dbf table.  One of the final processes in the model is Collect Values (set as a parameter), which is intended to add the dbf to the MXD Table of Contents when the model is run from its dialog.  In the MXD's Geoprocessing Options, the option is enabled to "Add results of geoprocessing operations to the display".

Until recently, the model worked fine; specifically, the output dbf was added to the TOC as intended.  But now, this is no longer happening.  Yet, it does work if I run the tool in Edit mode & I enable Add to Display on the Collect Values output.  I have read & re-read the Help documentation, user forums, etc., & have tinkered with the model & the MXD, but to no avail.  My guess is that Collect Values has somehow become corrupted in my ArcMap install.  I started having this issue while at version 10.4.1, but migrating to 10.5.1 did not resolve the problem.  Any thoughts regarding what might have gone haywire?

*Note: my model does not use an iterator; it is designed to generate only one mailing list per run.

Thanks,

-Chris

0 Kudos
0 Replies