Can't compute census data difference between two shapefile layers

1967
2
04-10-2013 05:29 AM
DonaldLund
New Contributor II
I have census data by school district in two layers, each layer representing a point in time, five years apart. The layer is in a shape file. I would like to somehow compute the difference between the two census values for each school district and plot the five year change by district. I can't figure out how to do this. It seems like I should be able to join the two layers, but I keep getting this:

The number of matching records for the join:
- Unexpected error encountered.
- No matches found by joining [UNSDLEA10] from <201310_ot_district_totals> with [UNSDLEA10] from <200810_ot_district_totals>.

I've tried using several fields that should match, but get the same result. I do joins all the time and have never run into this problem.

The two layers are identical in every respect except for the "Count" which is the census data for the district.

The layers were created by joining census data from a spreadsheet to school district shape files, then exporting the resulting data to a shapefile. I am trying to join the shapefiles so that both "counts" appear in the same layer. At least then I should be able to compute a difference (I think).

I would appreciate it if anyone could throw me a bone (or some bread crumbs) re. this.
0 Kudos
2 Replies
MelanieSummers
Occasional Contributor III
Hi Donald,

Are the fields you are joining by the same type of field? If you begin an editing session are there any leading spaces in one but not the other? If you'd like to upload your data I can take a look at it as well.

Best,
Melanie S.
0 Kudos
marieducharme
Occasional Contributor

Hello Donald,

I just had a very similar issue. I was using a shp and a gdb table. I converted my shp into a feature class, and that solved the issue.

Maybe try exporting your shapefile to a gdb.

Good luck

0 Kudos