Calculating field on joined table populates attributes with ObjectID not the choosen field.

2151
3
11-20-2015 01:30 PM
GerryGabrisch
Occasional Contributor III

I have a feature class of building footprints and a surface (LiDAR highest hit - LiDAR last return).  I am trying to use this surface to estimate the height of the buildings.

Transferring the values from the raster to the polygons should be a straight forward operation using add surface information but that tool is useless and returns a 99999 error code.

I tried the Zonal Statistics as a Table, then joined the table using the object ids.  I want to populate an existing field in the feature class with the mean value from the zonal statistics output but the field calculator (both within the attribute table and the Toolbox tool) populate the attribute with the objectID value.  This is odd behavior.

Both data are in the same projection, UOM, datum....

I do not understand why this is happening.  Is this a know bug or a problem specific to my installation?

Should I accept that I should export the join to a new FC and just clean up the e-trash later?

0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Even though you got the dreaded 9's have you examined the report in the Result window? (customize, results, then examine the tree, particularly your inputs, environments and message)

GerryGabrisch
Occasional Contributor III

Yes, Dan, I have.  The input parameters are good, there is no other information other than what is shown below.Capture.PNG

0 Kudos
Manuel_EderMamani_Yanque
New Contributor

Have you tried to convert the raster surface to a tin surface; I had the same trouble adding surface information.

It worked for me, I converted my raster surface to a tin surface and then it just work !!!....

Hope this works for you !!!...

0 Kudos