Calculate Tool on Model Builder

624
2
Jump to solution
06-28-2013 11:12 AM
ShikoNjuno
Occasional Contributor
Hi I'm new to Model Builder and I'm just trying to figure stuff out.
I am attempting to utilize the "Calculate Tool" to compute both user input values and raster values.

I keep getting an error message that says the model "Failed to Execute" the calculation.
So I tried just a simple 3 + 5 computation and it still didn't work.i.e. I don't get any output.

Is there a setting that I need to have selected or anything?
0 Kudos
1 Solution

Accepted Solutions
ShitijMehta
Esri Regular Contributor
Hi Shiko,
I am assuming you are talking about the Calculate Value tool in ModelBuilder.

Key is to have a correct output data type which can be set from the the 3rd parameter on the tool dialog. If that does not work, share a screen shot of the tool dialog with your values.

View solution in original post

0 Kudos
2 Replies
ShitijMehta
Esri Regular Contributor
Hi Shiko,
I am assuming you are talking about the Calculate Value tool in ModelBuilder.

Key is to have a correct output data type which can be set from the the 3rd parameter on the tool dialog. If that does not work, share a screen shot of the tool dialog with your values.
0 Kudos
ShikoNjuno
Occasional Contributor
Thanks Shitij.....I realized I should have been using the Calculate Raster Tool instead of the regular Calculate Tool.
And yes...I agree with the Type being a key issue that I ran into a number of times.
It's working okay now.
Cheers
:)
0 Kudos