Calculate Field in Model Builder Ignores Selection

01-15-2013 04:44 AM
New Contributor III
I am trying to execute a tool in model builder whereby I want to perform Calculate Field on selected records only. 
1. I run Select by Attribute and run a query within that tool to select some records. 
2. I then run Calculate Field on ONLY those selected records.  When I run these two, the Calculate Field ignores the selected records and simply performs the Calculation on all the records.  This is only a small part of the whole model, but necessary.

I've run the Select by Attributes tool individually then gone into the attribute table and verified that the records that I specified were selected correctly.  Then I run the Calculate Field in Model Builder individually and it ignores the selection. 

I tried another test.  I cleard out the records in that field and performed the the Select by Attribute individually in Model Builder then perform Field Calculator manually in the Attribute Table and it  runs as expected... performs in the selected records only.  Does anybody have any ideas?
1 Reply
MVP Esteemed Contributor
Have you connected the output of Select By Attributes as the input to Calculate Field? Selected sets only work with layers (not feature classes).
0 Kudos