ArcMap Background Processing in Python

1200
12
01-15-2019 06:07 AM
UMUTÜÇOK
New Contributor II

Hi,

Whenever i look at disable / enable background processing in ArcMap due to unlimited bugs and errors of ArcMap, ESRI referred their documents which you need to click the button in geoprocessing options.

However, I authored a program and i need to copy features as using "Feature Class to Feature Class tool" from an SDE workspace into filegdb. When i want to do that in Python console in ArcMap or ArcToolbox it gives me error if i enable Background processing. If i disable, no error occurs.

The main problem is there is no access in arcpy to disable background process or i could not find.

But the most ridiculous thing in this process, Feature class to feature class is very basic tool. Even in that tool, geoprocess crashes.

I prepared a video for this, you can watch.

arcmap gp background hatasi - Streamable 

0 Kudos
12 Replies
DanPatterson_Retired
MVP Esteemed Contributor

If your workflow can be done in ArcGIS Pro, that is an option to the background geoprocessing issues, since it is no longer needed

0 Kudos
UMUTÜÇOK
New Contributor II

Can you refer a document to disable background processing in Python? Because i did not tell that i can not disable bg processing in ArcMap or ArcGIS. 

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

What version of ArcGIS Desktop are you using?  What version is the EGDB and what DBMS?  Do you have 64-bit Background Geoprocessing installed?

0 Kudos
UMUTÜÇOK
New Contributor II

Thanks for your reply,

Did you watch the video? Issue is irrelevant about versions but i wrote:

ArcGIS Desktop 10.6.1.

SQL Server 2016 

 

No I didn't. Because I don't want to use background processing. I want to disable it. 

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

Yes, watched the video, but it didn't tell me what version of ArcMap you are using, what version of EGDB, or what DBMS.  Since you don't know why it isn't working, how are you sure it isn't version related?  Have you tried it on multiple versions?  Sometimes bugs get introduced in new versions of ArcGIS Desktop, e.g., regression defects, so knowing the version is a critical piece of information.

Ostensibly, you want to disable background processing since it breaks your code.  There are cases where the bug isn't in background processing, per se, but the 64-bit Geoprocessing component that can be installed separately.  Since the video didn't indicate whether you had installed 64-bit Geoprocessing, I asked.

Since you seem to have it all sorted out, I will leave you to it.  Good luck.

0 Kudos
ModyBuchbinder
Esri Regular Contributor

If you are connecting to SDE you need oracle client 64bit

It should be configure the same way the 32bit oracle client that is used by ArcMap.

Have fun

Mody

0 Kudos
UMUTÜÇOK
New Contributor II

It's not about client. I didn't say that i can not connect to SDE. Did you really read what i wrote? I told I can not run geoprocessing tool in case of enabled background processing instead of disabled.

0 Kudos
MarcoBoeringa
MVP Regular Contributor

Hi Umut,

Interesting issue.

One thing I did notice though, when watching that video, is that your output location is set to your user profile, and that the failure is about not being able to create the output table. Have you also attempted to write to another drive?

I am wondering, since the background processing runs in another process, if that process potentially has different rights, and simply has no access to your user profile, and hence fails to write the required new feature class to the file geodatabase.

0 Kudos
XanderBakker
Esri Esteemed Contributor

Have a look at this related thread https://community.esri.com/thread/182608-can-background-processing-be-enableddisabled-in-arcpy#comme... where bixb0012 provided some valuable insights. Did you try to run the process as a stand alone script? This will not trigger the background geoprocessing.  

0 Kudos