ArcGIS not creating a buffer around a line

1135
5
07-19-2011 07:39 AM
DavidVan_Riper
New Contributor
I'm trying to create a 150 meter, full, flat buffer around a line, but ArcGIS (both 9.3 and 10.0) does not create the whole buffer every time I run the buffer tool. The buffer tool itself finishes, but it only creates a very small polygon. The line is relatively complex - it was generated using Network Analyst's Create Service Area tool.

The buffer tool successfully creates the buffer when the distance is set to 135 meters, but any distance value larger than 135 fails. The 150 meter distance works fine when the round option is selected. If I make the buffer distance large (300 meters), the buffer is created successfully.

Does anyone have any insights about this problem?

Dave Van Riper, GISP
Minnesota Population Center
University of Minnesota
0 Kudos
5 Replies
AndrewChapkowski
Esri Regular Contributor
Can you post your feature class?

Are you running ArcInfo?


Thanks
0 Kudos
DavidVan_Riper
New Contributor
I am running ArcInfo.

Here is the shapefile with the three lines. The line in the far southwest corner is the one giving me problems.

Dave Van Riper
0 Kudos
AndrewChapkowski
Esri Regular Contributor
Hey Dave,

It appears you have a projection problem.  If you project your data from NAD_1983_UTM_Zone_15N to WGS1984 it works.  The one feature in the southwest might be outside the UTM Zone 15N.

I've attached the image of my output.

To test this, I did the following:
1. Project your attached file to WGS-1984 using the project tool.
2. Using the newly projected data, run the buffer tool to create the buffer.

For testing purposes, I used the following code after I did the projection:
import arcpy
fc = r"C:\TEMP\scratch.gdb\line1450_proj"
rows = arcpy.SearchCursor(fc)
for row in rows:
    arcpy.Buffer_analysis(row.Shape,
                          arcpy.CreateUniqueName(r"c:\temp\scratch.gdb\buff"),
                          "150 Meters",
                          "#",
                          "FLAT", "ALL"
                          )
                          
del row, rows
print 'finished'


This will loop through all three records and create a buffer for each shape in the LineM feature class.
0 Kudos
DavidVan_Riper
New Contributor
Thanks, Andrew!

The area of interest is right in the middle of UTM Zone 15, so I'm surprised that was the problem. Also, because the larger and smaller buffer distances worked but not 150 meters.

But, I'll take this solution.
0 Kudos
markdenil
Regular Contributor II
It seems to be a problem with line complexity and the flat option. Generalizing the line makes it work fine. Try finding a level of generalization that will weed out enough verticies to let the tool work without getting confused, but not harm the characterization of the line network.
The line nests that work are both quite angular, with lots of straight lines.

The idea about being ouside the UTM zone is unlikley, unless you are very far outside it: say, the other side of the world (which is infinetly far from the central meridian). UTM zones are 6 degrees wide to keep distortion within 'acceptable' limits, not because they stop at the edge.
0 Kudos