Error connecting to Workgroup Geodatabase

2866
16
Jump to solution
10-12-2015 12:10 AM
Highlighted
Occasional Contributor II

I am trying to connect to a Workgroup Geodatabase, when trying to exploring this geodatabase I get an error that says: “Failed to connect to database. Maximum Number of connections to instance is reached”. However, only three users are connecting to this geodatabase which is less than the TEN allowed users.

What might be the issue here?

Thank you and Best Regards,

Clip_3.jpg

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

It should be something like this.....  "Database_Server_Workgroup_1031"

Make sure that you have a license for the following product:  ArcGIS Server for Workgroup (any license level: Basic, Standard or Advanced)

That should get you moving.....

--- George T.

View solution in original post

0 Kudos
16 Replies
Highlighted
Regular Contributor III

Some things I would recommend to check:

1. The Server_config table for the license which was used to authorize the geodatabase. Check the AUTH_KEY parameter value.

2. The process_information table for the actual number of connections to the geodatabase, when you get that message.

Do you have Map Services running for that geodatabase? It could be consuming connections too.

Highlighted
Occasional Contributor II

Hi Asrujit,

Regarding the license I used no license for authorizing this Geodatabase, since it is a Workgroup GDB; I connected to the database server, and created it (in ArcMap), and it did not ask me for any license.

Regarding the number of connections, I had only 3 connections with NO map services connected to this GDB.

Best,

0 Kudos
Highlighted
Regular Contributor III

You need an SDE Workgroup license for enabling an instance before creating a sde workgroup geodatabase.

From your description, it seems that you are using an SDE Personal gdb, which has a limitation of 3 connections..

As suggested in my last post, please check the Server_config table in SQL Server Management Studio

Highlighted
Occasional Contributor II

Hi Asrujit,

Thank you for the helpful contribution!

Actually, I got confused. I came from the enterprise geodatabase environment, and new to the Workgroup GDB; when I create an enterprise geodatabase, or enable an enterprise database to be enterprise GEODATABASE, I am asked to provide an authorization file (in the screen shots below). However, in the case of Workgroup GDB, I can create it without providing any authorization (in the third screenshot). At what level should I authorize the workgroup geodatabase? May you please explain?

May you please also elaborate how can I check the Server_config table in SQL Server Management Studio (My experience with SQL Server is shallow)?

Best Regards,

1- Creating an enterprise Geodatabase; it Asks for an authorization file

Clip_1109.jpg

2- Enabling enterprise Geodatabase; it also asks for the authorization file

Clip_1108.jpg

3- Creating a Workgroup Geodatabase; it DOES NOT ask for any authorization file!

Clip_1110.jpg

0 Kudos
Highlighted
New Contributor III

The reason you are not being prompted for an authorization file in your third screenshot is because your SQL Server Express instance has already been authorized to store workgroup/personal geodatabases.  This authorization would have occurred when you ran the ArcSDE for Microsoft SQL Server Express installation wizard.  During this process you designate a SQL Server Express instance to use as a database server, a server administrator is added to the database server, a SQL Server Express instance is enabled to store geodatabases, and the software is authorized.

ArcGIS Server Workgroup Microsoft SQL Server Express installation

You create geodatabases on database servers in the Catalog window. Creating a geodatabase creates a new database on a SQL Server Express instance.

ArcGIS Help (10.2, 10.2.1, and 10.2.2)

As Asrujit SenGupta mentioned above, the 3 connection limit indicates that you may be using an ArcSDE Personal geodatabase rather than a Workgroup geodatabase.

You can run a simple statement in a new query window in SQL Server Management Studio to find the contents of the SDE_server_config table. Check the AUTH_KEY parameter value.

SELECT *

  FROM [DatabaseName].[sde].[SDE_server_config]

Highlighted
Occasional Contributor II

Many thanks Quin for the prompt response,

Is the ArcSDE for Microsoft SQL Server Express installation wizard available for ArcGIS 10.3 version?

I am not able to find it within the ArcGIS desktop 10.3 installation package.

Thank you also for the script!

0 Kudos
Highlighted
Regular Contributor III

Yes, it is available for download on My Esri. Should be named 'Database Server' I recall.

Highlighted
Occasional Contributor II

Asrujit, I still struggling with the license, I've installed the database server, and it did not prompted me to provide a license. Please see below

1- Installing the database server

Clip_1111.jpg

2- Installing SQL Server Express (the full installation of SQL Server is not included in the screenshots)

Clip_1112.jpg

3- Entering the Server Parameters

Clip_1113.jpg

4- The login was added Successfully

Clip_1114.jpg

5- The installation completed and I did not provide any license!

Clip_1115.jpg

0 Kudos
Highlighted
Esri Frequent Contributor

Hani,

What is the full name of the ".exe" that you are installing?

If it did not ask for a licence file, as it would in a ArcGIS for Server Workgroup, then you must be using the Database Server for Desktop.

Here is the documentation for this specific install:

Beginning at ArcGIS 9.2, ArcGIS for Desktop Standard and Advanced includes an installation of Microsoft SQL Server Express. These software products also include ArcSDE capabilities to support enterprise geodatabases in SQL Server Express for up to three simultaneous desktop users.

Types of geodatabases—ArcGIS Help | ArcGIS for Desktop

Hope this clears up some of the confusion..........

If you want "True" workgroup level licencing you need to re-install with the correct Database Server install media.

-George

Enterprise GIS

--- George T.