connect oracle 12c from arcgis for desktop and server 10.3.1

06-22-2017 11:43 PM
New Contributor III


Problem: We can not connect to oracle 12c db from ArcGIS desktop and server 10.3.

db server info: Oracle 12c installed on Red Hat Enterprise Linux Server 7.3 OS

GIS Server:  arcgis for desktop and server 10.3.1 Installed on the same machine (windows server 2012 r2)

Oracle client info: oracle 12c 64x and 32x client installed on gis server. Oracle 12c 64x client before 32x oracle client on windows PATH Variable.

Other info

- Oracle DB and listener running, we connected oracle db from sql developer.

- We have moved oracle 11g db (with full backup) to new oracle 12c.

arcgis for desktop and server Connection errors attached. 

"Database Connection

Failed to connect to the specified server. underlying DBMS error [unknown errorNo   extended error.]

0 Kudos
11 Replies
Occasional Contributor III


Have you tried to telnet?

I assume port 1521 is open for both the machines?

Have you tried to do an TNS entry for the Oracle client?


0 Kudos
New Contributor III


Yes, I did telnet connection to oracle db server.

 its ok.     tnsping and TNS entry for oracle client


0 Kudos
MVP Esteemed Contributor

What happens if you just type GIS as your Oracle instance in Database Connection dialog box?

Think Location
0 Kudos
MVP Regular Contributor
  1. The successful connection using SQL Developer that you mentioned. Is the SQL Developer on the GIS Server?
  2. Were you able to connect using SQLPlus in Command Prompt on the GIS Server?

Considering you are using the default 1521 port, you don't need to mention that in the connection string. Just try IP/GIS.

0 Kudos
New Contributor III

Our Oracle version 12.2

0 Kudos
Esri Esteemed Contributor

The system requirements for 10.3 do not mention Oracle 12.2, just 12.1. In fact, ArcGIS 10.5.1 doesn't mention Oracle 12.2 either. I wouldn't expect the latest builds of Oracle to operate with an old version of ArcGIS.

- V

New Contributor II


   I too got the similar issue. This is the problem with user credentials. You might have installed and configured the database with one user and now trying to access the database with another user or same or other domain. In this case you have to give permissions or share the oracle client folder with the new user.

-Prasad Amujuri

0 Kudos
New Contributor III

I had a similar issue - couldn't connect oracle 12.2 from 10.4.1 ArcGIS desktop. I have verified correct version of oracle client got installed and other requirements were met. I can TNSPING and connect successfully in SQL developer. Can anybody please confirm the issue is with unsupported version/release?

0 Kudos
New Contributor

We have the same issue, did you find solution for your problem?

0 Kudos