Select to view content in your preferred language

Spatial reference does not exist in the data source

3305
12
01-12-2021 03:28 AM
hanakohinonn
New Member
  • Hi, Now I have a polygon layer, and I want to convert it to raster.

So, I tried to polygon to raster, however, the error came up with.

ERORR:999999

Spatial reference does not exist in the data source.

I have no ideal to solve this problem, please help me.

 

Thanks in advance.

0 Kudos
12 Replies
hanakohinonn
New Member

Hi,Dan

Thank you for your message!

I create the shapefile ,and I had no problem when I load the shapefile. 

I Succeed in Repair geometry, but failed Copy Features. I got the message below.

ERROR:000210

Unable to produce output. The data may be locked, the path may be incorrect, or access may be restricted.

Then I checked my data folder, and found the "lock file". (please look at the picture.)

However, I don't know this is the cause because there is another shp file.

 

Thank  you.

0 Kudos
DanPatterson
MVP Esteemed Contributor

Are you working on your local C: drive?

If Repair Geometry worked, just use Copy Features and specify a different geodatabase to save it in.

Reusing the same stuff isn't going to help, so change the name and location for the copy features to make sure that you have permissions to save the file.  Create a new geodatabase perhaps and specify a simple output file name  (eg.  c:\Temp\temp.gdb\X )


... sort of retired...
BWang
by
New Contributor

Hi Hanako,

Can you try another way to copy the data to a new shapefile? For example, Exporting the data to another shapefile. You can follow the document below.

Exporting features

https://desktop.arcgis.com/en/arcmap/latest/map/working-with-layers/exporting-features.htm

0 Kudos