Made a shapefile with points and a complete attribute table. Tried to open it today, and the shapefile isn't showing any points or attribute table. The table seems to be a separate DBF?

1030
4
09-03-2020 10:44 AM
MiaHarrell
New Contributor

Hello! I've attached a picture of my problem. I assume it's an easy fix, but I just can't find the solution online. My HighStrengthWaste_Points (.shp) has no points or attribute table! The actual data seems to be the DBF HighStrengthWaste_Points(6) under it. Is there a way to put them back together? Why did they separate in the first place when they were together when I created them? Or did I add the data incorrectly? 

r/gis - Made a shapefile with points and a complete attribute table. Tried to open it today, and the shapefile isn't showing any points or attribute table. The table seems to be a separate DBF?
Also, sorry if I'm doing this forum thing wrong. I only made this account to ask this one question and have never actually used these forums before. Recommendations on where else to go for help would also be very much appreciated. 
0 Kudos
4 Replies
KoryKramer
Esri Community Moderator

Hi Mia Harrell‌  A shapefile, as you've observed, is made up of different files.  You can see all of the possible extensions here: Shapefile file extensions—ArcMap | Documentation 

The first three are required:

It looks like maybe you're using ArcMap?  

How did you create the shapefile?  In ArcMap or other software?

When you go to the folder where the shapefile is stored, do you see all of the component files there?  Something like this:

How did you add the shapefile to ArcMap?  You can drag/drop it from the Catalog window:

and from a quick check that I just did, you should also be able to drag just the .shp from the Windows folder into ArcMap.  I also tried selecting the .shp and .dbf and dragging/dropping into ArcMap but still get a good result.

Let us know about what your contents look like in Windows file explorer.

Thanks!

MiaHarrell
New Contributor

Hi Kory Kramer‌!

Yes, I am using ArcMap, and I created the shapefile in ArcMap  Although I have to access ArcMap through Citrix which is probably where the nightmare starts. There are seven different files for my shapefile. I first tried just opening the mxd that contained the shapefile/data by copying all the related files to Citrix's drive (I can't access my own computer's files through Citrix, and Citrix seems to wipe its drive after each session, so I had to copy my work to Citrix's drive to open them), but then it gives me this red exclamation point of death. 

 

I think school taught me that I just need to reconnect the source to HighStrengthWaste_Points to get it working again, but that didn't work. I got an error -

So instead I tried to just re-add the shapefile which is how I got to the shapefile with no points or attribute table but a separate dbf. A lot of the issue may be with Citrix's drives and being unable to just directly connect to my computer's files. I can't drag anything directly from my computer files into ArcMap while it's being run through Citrix  

To be honest, this is what the content looks like in my computer files because of how Citrix was saving it while I was first making it -

It's really confusing having so many versions of the same files instead of having them just replace their older versions. 

When I try to open the most recent shapefile HighStrengthWaste_Points (2).shp, I get the error below.

I can add the older versions HighStrengthWaste_Points (1).shp and HighStrengthWaste_Points.shp, but they're empty.

 

When I add the most recent dbf HighStrengthWaste_Points (6).dbf, it attaches to the (1) shapefile, but there's still no points or attribute table for the shapefile. 

Sorry that this got so complex, and thank you so much for replying! Don't stress yourself over my problem, I'll understand if you can't help!

0 Kudos
KoryKramer
Esri Community Moderator

Hmm, yeah, this got real complicated real fast   It seems like you probably need to figure out who the Citrix admin is and explain the issue to that person.  I'm pretty sure there are ways to configure Citrix so that you can use drives on the client (i.e. your local machine), but I'm not a Citrix guy and can't speak with any authority on that.  

From the description and screenshots you provided (thank you for that by the way, screenshots are like gold in forums!) I can see that some of your .shp and .dbf files are 1 kb, but note how the ...(6).dbf is 4kb.  The error that you showed tells us exactly what is happening.  The number of records in the .shp doesn't match the number of records in the .dbf.  

Unfortunately, I'm not sure that I can be of any help on this one.  I think your best best is to demonstrate and explain the problem to a Citrix admin and see if they can get your files/drives set up either so that you can work directly from your local drives, or provide you with a location available to the Citrix machine where you can store your GIS data.

Good luck!

Egge-JanPollé1
MVP Regular Contributor

Hi Mia Harrell,

Welcome to GeoNet! No, you are not "doing this forum thing wrong", not at all. This forum, the community, is there to help. So, please post your questions and maybe you will receive an answer, maybe even a correct one! (And, as you can see, there is also a lot of Esri staff hanging around here... I guess the answer by Kory Kramer‌ is useful to you.)

The good thing about this whole game of questions and answers here is: it is all online, out in the open, so the information shared here is beneficial to the community at large.

Personally, I have learned a lot from just following the discussion here: reading a lot of questions, seeing what others are posting as an answer, posting an answer myself every now and then...

So, you are invited to come back to this forum regularly. And don't forget: if you happen to know the answer to a question, please share it with us.

BR,

Egge-Jan