Update AUTH_KEY

2134
14
Jump to solution
02-20-2014 06:50 AM
Highlighted
New Contributor II
Good morning All,

I got a sql spatial database from our client. I found their version is 10.0 but ours is 10.1. So I created a direct database connection in ArcCatalog and upgraded the geodatabse. Afterward, I went back to SSMS to check the AUTH_KEY in SDE_server_config table. The license is still 10.0 in the cell. I run the "sdesetup -o update_key" command line where the SDE SERVER is sitting. I got an errors saying: Failure to access the DBMS server (-409). Error upgrading authorization key. Can anyone help?

Thanks!
-yl
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor
I hadn't realized this; thanks for letting me know.  My only other suggestions for syntax and parameter sequencing are:

sdesetup -o update_key -d SQLSERVER -u sa -p sa -D TFIPS -s hostname\sql2008r2 -i sde:sqlserver -l "C:\Program Files\ESRI\License10.1\sysgen\keycodes"   sdesetup -o update_key -d SQLSERVER -u sa -p sa -D TFIPS -s hostname -i sde:sqlserver\sql2008r2 -l "C:\Program Files\ESRI\License10.1\sysgen\keycodes"  


This assumes your database name is TFIPS and your instance name is sql2008r2 based on your screenshots.  Otherwise, you may need to open a support ticket with Esri.

View solution in original post

Reply
0 Kudos
14 Replies
Highlighted
MVP Regular Contributor
Good morning All,

I got a sql spatial database from our client. I found their version is 10.0 but ours is 10.1. So I created a direct database connection in ArcCatalog and upgraded the geodatabse. Afterward, I went back to SSMS to check the AUTH_KEY in SDE_server_config table. The license is still 10.0 in the cell. I run the "sdesetup -o update_key" command line where the SDE SERVER is sitting. I got an errors saying: Failure to access the DBMS server (-409). Error upgrading authorization key. Can anyone help?

Thanks!
-yl


A few questions...


  • Are you referencing a 10.1 keycodes file when running the sdesetup -o update_key command? 

  • For the -i parameter in the sdesetup command, are you using an ArcSDE service or a direct connection?  It might be helpful to post the entire command you are running (minus the SDE password) so we can see the connection you're trying to pass. 

  • After the upgrade completed, can you still connect to the 10.1 GDB via ArcCatalog? 

  • Did you receive any errors at all during the upgrade? 


I don't think you are required to re-authorize your geodatabase simply because of an upgrade from a technical standpoint; but my guess is that you are doing so from a legal standpoint in order to not use your client's license code. 

This blog discusses the general process for re-authorizing a 10.1 geodatabase:

http://blogs.esri.com/esri/supportcenter/2013/06/04/updating-the-license-for-enterprise-geodatabases...

I'm also curious to know what the VERSION table in ArcSDE contains.

Another option is to run the Post Installation for ArcSDE, select custom, and select only the option to authorize the geodatabase.
Reply
0 Kudos
Highlighted
New Contributor II
A few questions...


  • Are you referencing a 10.1 keycodes file when running the sdesetup -o update_key command? 

  • For the -i parameter in the sdesetup command, are you using an ArcSDE service or a direct connection?  It might be helpful to post the entire command you are running (minus the SDE password) so we can see the connection you're trying to pass. 

  • After the upgrade completed, can you still connect to the 10.1 GDB via ArcCatalog? 

  • Did you receive any errors at all during the upgrade? 


I don't think you are required to re-authorize your geodatabase simply because of an upgrade from a technical standpoint; but my guess is that you are doing so from a legal standpoint in order to not use your client's license code. 

This blog discusses the general process for re-authorizing a 10.1 geodatabase:

http://blogs.esri.com/esri/supportcenter/2013/06/04/updating-the-license-for-enterprise-geodatabases...

I'm also curious to know what the VERSION table in ArcSDE contains.

Another option is to run the Post Installation for ArcSDE, select custom, and select only the option to authorize the geodatabase.

Hi William,

The command line is:
[ATTACH=CONFIG]31632[/ATTACH]
For the -i parameter, I am not sure what argument should be input. In this case, I type in sql server instance.
The geodatabase is with dbo schema, so I access to the geodatabase by sa user or other dbo users. There is no problem if I directly connect to 10.1 GDB through ArcCatalog. Finally, under the SDE_version table, there is only one row:
[ATTACH=CONFIG]31633[/ATTACH]

Thanks!
-yl
Reply
0 Kudos
Highlighted
New Contributor II
A few questions...


  • Are you referencing a 10.1 keycodes file when running the sdesetup -o update_key command? 

  • For the -i parameter in the sdesetup command, are you using an ArcSDE service or a direct connection?  It might be helpful to post the entire command you are running (minus the SDE password) so we can see the connection you're trying to pass. 

  • After the upgrade completed, can you still connect to the 10.1 GDB via ArcCatalog? 

  • Did you receive any errors at all during the upgrade? 


I don't think you are required to re-authorize your geodatabase simply because of an upgrade from a technical standpoint; but my guess is that you are doing so from a legal standpoint in order to not use your client's license code. 

This blog discusses the general process for re-authorizing a 10.1 geodatabase:

http://blogs.esri.com/esri/supportcenter/2013/06/04/updating-the-license-for-enterprise-geodatabases...

I'm also curious to know what the VERSION table in ArcSDE contains.

Another option is to run the Post Installation for ArcSDE, select custom, and select only the option to authorize the geodatabase.


Hi William,

The command line is:
[ATTACH=CONFIG]31632[/ATTACH]
For the -i parameter, I am not sure what argument should be input. In this case, I type in sql server instance.
The geodatabase is with dbo schema, so I access to the geodatabase by sa user or other dbo users. There is no problem if I directly connect to 10.1 GDB through ArcCatalog. Finally, under the SDE_version table, there is only one row:
[ATTACH=CONFIG]31633[/ATTACH]

Thanks!
-yl
Reply
0 Kudos
Highlighted
MVP Regular Contributor
Is sql2008r2 your instance name?  Try changing your -i parameter to include only the hostname...

-i sde:sqlserver:hostname

... or try separating them without specifying the SQL Server instance name ...

-i sde:sqlserver -s hostname
Reply
0 Kudos
Highlighted
New Contributor II
A few questions...


  • Are you referencing a 10.1 keycodes file when running the sdesetup -o update_key command? 

  • For the -i parameter in the sdesetup command, are you using an ArcSDE service or a direct connection?  It might be helpful to post the entire command you are running (minus the SDE password) so we can see the connection you're trying to pass. 

  • After the upgrade completed, can you still connect to the 10.1 GDB via ArcCatalog? 

  • Did you receive any errors at all during the upgrade? 


I don't think you are required to re-authorize your geodatabase simply because of an upgrade from a technical standpoint; but my guess is that you are doing so from a legal standpoint in order to not use your client's license code. 

This blog discusses the general process for re-authorizing a 10.1 geodatabase:

http://blogs.esri.com/esri/supportcenter/2013/06/04/updating-the-license-for-enterprise-geodatabases...

I'm also curious to know what the VERSION table in ArcSDE contains.

Another option is to run the Post Installation for ArcSDE, select custom, and select only the option to authorize the geodatabase.


Hi William,

The command line is:
[ATTACH=CONFIG]31635[/ATTACH]
For the -i parameter, I am not sure what argument should be input. In this case, I type in sql server instance.
The geodatabase is with dbo schema, so I access to the geodatabase by sa user or other dbo users. There is no problem if I directly connect to 10.1 GDB through ArcCatalog. Finally, under the SDE_version table, there is only one row:
[ATTACH=CONFIG]31636[/ATTACH]

Thanks!
-yl
Reply
0 Kudos
Highlighted
New Contributor II
Is sql2008r2 your instance name?  Try changing your -i parameter to include only the hostname...

-i sde:sqlserver:hostname

... or try separating them without specifying the SQL Server instance name ...

-i sde:sqlserver -s hostname


Hi william,

I changed but it didn't work. Same errors. If I don't change the authorization key, will it be problem with my client's license? Or will the geodatabase be affected for future administration?

Thanks!
-yl
Reply
0 Kudos
Highlighted
MVP Regular Contributor
The geodatabase should still work just fine without reauthorizing, but you may want to change the license key for legal reasons.  If none of the various syntax options are working for you with regard to the SDESETUP command, try using the Post Installation wizard for ArcSDE.  Choose the custom option and only select the box for authorizing a geodatabase.
Reply
0 Kudos
Highlighted
New Contributor II
The geodatabase should still work just fine without reauthorizing, but you may want to change the license key for legal reasons.  If none of the various syntax options are working for you with regard to the SDESETUP command, try using the Post Installation wizard for ArcSDE.  Choose the custom option and only select the box for authorizing a geodatabase.


Hi william,

I google about Post Installation Wizard. It is no longer with Version 10.1

"Summary
At the 10.1 release, the Post Installation Wizard is no longer part of the ArcSDE install. Prior to 10.1, the Post Installation Wizard could be used to create the application server service for 3-tier connections to be made to the geodatabase. The ArcSDE command line tools and application server service can still be configured by installing the ArcSDE application server and creating/registering the service manually."


My question is: how can I find the Post Installation Wizard for ArcSDE?
Besides, I read the ArcSDE Administration Command. However, I still confuse about -i parameter.
[ATTACH=CONFIG]31644[/ATTACH]
Should this be localhost or instance or others?

Thanks!
-yl
Reply
0 Kudos
Highlighted
MVP Regular Contributor
I hadn't realized this; thanks for letting me know.  My only other suggestions for syntax and parameter sequencing are:

sdesetup -o update_key -d SQLSERVER -u sa -p sa -D TFIPS -s hostname\sql2008r2 -i sde:sqlserver -l "C:\Program Files\ESRI\License10.1\sysgen\keycodes"   sdesetup -o update_key -d SQLSERVER -u sa -p sa -D TFIPS -s hostname -i sde:sqlserver\sql2008r2 -l "C:\Program Files\ESRI\License10.1\sysgen\keycodes"  


This assumes your database name is TFIPS and your instance name is sql2008r2 based on your screenshots.  Otherwise, you may need to open a support ticket with Esri.

View solution in original post

Reply
0 Kudos