Importing CAD data to geodatabase in ArcGIS 10.5

1370
5
06-12-2017 09:05 AM
Highlighted
New Contributor III

Hi,

i am using the CAD to Geodatabase tool to import DWG files to a geodatabase.

In ArcGIS 10.2 and 10.3, this works perfectly well.

But when I try to do the same thing in ArcGIS 10.5 (no matter if I use the tool in ArcMap or if I use a Python script), I get the following error:

000354 : The name contains invalid characters.

If this refers to table names in the DWG file myself, then I don't know what to do; I have no CAD software and cannot change the DWG files myself. And it wasn't a problem in earlier versions of ArcGIS...

Can somebody help?

Thanks,

Claudia

Reply
0 Kudos
5 Replies
Highlighted
Occasional Contributor III

I haven't heard of this error before.  It would be a good one to send to technical support, probably with a sample drawing file.

Highlighted
Occasional Contributor

Running into this problem, have you found a solution?

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Two things to try:

  • Disable background geoprocessing from the Geoprocessing Menu->Geoprocessing Options
  • Add the layer to a Data Frame. Does it have a hyphen in the name?  If so, rename it without a hyphen.
Highlighted
Occasional Contributor

Thanks for the advice, however, my background processing was already disabled, and there were no special characters. 

The tool was behaving very oddly, as it would work on occasion.  I was operating on an Iterate Dataset tool to batch convert some drawing files.  I wanted to specify specific layers in the dwg to convert to a feature class, so I was using the output of the Iterate Dataset tool for the input of Make Feature Layer tool using a definition query.  The problem I was having was in my syntax of the input feature option in the Make Feature Layer tool:  %output%\polyline was my initial input.  %output% being the variable of the iterate dataset which should be the pathname to the dwg iteration.  The tool started working when I changed my input to %output%\\polyline, with two slashes.  

Highlighted
Esri Frequent Contributor

Thx for the update Tony - good to hear it's working with the corrected syntax.

Reply
0 Kudos