The feature could not be created. The geometry is invalid.

08-20-2013 02:14 AM
New Contributor

Trying to create a polygon or polyline feature from point data, by creating a shapefile and then using the editor to create the feature from the point data. The first feature was created fine but each subsequent one I have tried to create has not worked, it is not snapping to the points like it did for the first example and when you try to save edits an error message pops up saying "The feature could not be created. The geometry is invalid." Has the file become corrupted some how? The first feature was created fine, the coordinate systems were defined and the data in the attribute table for the point data is fine, so can't find anything wrong with the geometry. Anybody else had this problem and know how to fix it?

Tags (2)
0 Kudos
5 Replies
New Contributor
Solved it by closing the program and restarting it. Sounds simple, but it worked.
0 Kudos
Occasional Contributor
May I know what version of ArcMap are you using? if you're using 10.2, you may want to dl the patch for shapefile issues. If not, you can try it with a new blank map doc. 🙂
0 Kudos
New Contributor

I am also facing the same problem.i have checked all the coordinates are same.i tried restarting the progrma bt it is still not working..i am not being able to make a single feature using any feature class.

0 Kudos
New Contributor II

I had this issue, I was able to resolve it by going to the feature class properties in ArcCatalog > Featuire Extent > Recalculate.

New Contributor III

I was having this same problem.  Found out the problem was... my next line was only 50+ feet and I had SNAPPING turned on.  When entered, the line immediately snapped back to ZERO length -invalid geometry.  Turned SNAPPING OFF - problem fixed.