Error 000535 when using Sort Coded Value Domain tool

4212
6
Jump to solution
05-09-2014 04:47 AM
JessicaGooch1
Occasional Contributor

Hi-

I am trying to reorder coded values in a domain in a geodatabase and I am currently getting ERROR 000535: Workspace does not exist when using the Sort Coded Value Domain tool.  Any ideas how to get this to work?

Thanks!
-Jessica

1 Solution

Accepted Solutions
AsrujitSengupta
Regular Contributor III
You may be encountering NIM100594:
[ NIM100594 - Any tool in the Domains toolset fails and returns the error, "ERROR 000535: Workspace does not exist." when run with 64-bit Background Geoprocessing enabled.]

http://support.esri.com/en/bugs/nimbus/TklNMTAwNTk0

Suggestion: Disable background geoprocessing by clicking on the geoprocessing menu --> geoprocessing options --> uncheck the box next to "enable" under the background geoprocessing section --> Try the tool again.

View solution in original post

6 Replies
NidhinKarthikeyan
Regular Contributor II
Please provide the version of ArcGIS for Desktop and ArcSDE(Including the version of RDBMS). There are some known issues in 10.2.1.
0 Kudos
JessicaGooch1
Occasional Contributor
ArcGIS 10.2.1 for Desktop.

The domains were originally created in a 9.3 SDE and we recently upgraded to 10.2.1.

The gdb I am working on was created from a map package using feature classes from the 10.2.1 SDE so I am not connected to our SDE when I am trying to reorder the domains.

I hope I answered your questions correctly, I am relatively new to SDE.

I did create a dummy file geodatabase, created a domain, added three values and attempted to reorder the domain and I got the same error if that helps (I also tried the same thing using a personal gdb).

Thank you!!!
0 Kudos
AsrujitSengupta
Regular Contributor III
You may be encountering NIM100594:
[ NIM100594 - Any tool in the Domains toolset fails and returns the error, "ERROR 000535: Workspace does not exist." when run with 64-bit Background Geoprocessing enabled.]

http://support.esri.com/en/bugs/nimbus/TklNMTAwNTk0

Suggestion: Disable background geoprocessing by clicking on the geoprocessing menu --> geoprocessing options --> uncheck the box next to "enable" under the background geoprocessing section --> Try the tool again.

View solution in original post

CourtneySpillane
New Contributor II

This helped, thanks!

0 Kudos
JessicaGooch1
Occasional Contributor
Genius! Thank you so much asrujit!
That worked perfectly.
0 Kudos
DannyEngle
New Contributor

Same issue with 10.2.1, disabled background and resolves

0 Kudos