Address Locator not Finding Addresses

4827
21
Jump to solution
09-02-2016 09:14 AM
RachelAlbritton2
New Contributor

I've created and address locator (dual range) using a reference set from our state GIS reference center. The street layer is formatted for to use for address location. My streets layer is in a file geodatabase (stand alone feature class) and my address locator is on a separate folder. 

 

I'm using 10.4.1

 

To trya nd trouble shoot, I also ran through the same process to create a locator using ESRI's tutorial data for geocoding and the tutorial guide. I'm getting the same results (No Address Found). 

 

I've read this post where a user had the same issue in 10.3.x that required a Service Pack Update to fix this issue, so I'm wondering if this, again, got overlooked when the software got upgraded to 10.4? Has anyone else had that issue. Is there something that I am overlooking?

Reply
0 Kudos
1 Solution

Accepted Solutions
JoeBorgione
MVP Esteemed Contributor

Check this:  open up your locator properties (right click, properties).  Scroll down to the Geocoding Options and expand it by single left clicking the + sign.  Look at the list and make sure the Match with no zones = YES.

This ensures the locator will make a match whether or not your streets feature class has City, State, Zip etc information.  I thought this was going to default to YES in v 10.4, so if it's already yes, you've got another issue going on and we can take it from there.

can't wait to retire....

View solution in original post

21 Replies
JoeBorgione
MVP Esteemed Contributor

Check this:  open up your locator properties (right click, properties).  Scroll down to the Geocoding Options and expand it by single left clicking the + sign.  Look at the list and make sure the Match with no zones = YES.

This ensures the locator will make a match whether or not your streets feature class has City, State, Zip etc information.  I thought this was going to default to YES in v 10.4, so if it's already yes, you've got another issue going on and we can take it from there.

can't wait to retire....

View solution in original post

RachelAlbritton2
New Contributor

Thanks Joe - That got it working on the ESRI dataset and let me narrow down my problem to some fields that needed reformatting on my dataset. 

Reply
0 Kudos
JustinConnerWR
Occasional Contributor II

This is still defaulting to "No" in 10.5.

Reply
0 Kudos
JoeBorgione
MVP Esteemed Contributor

Yeah, your'e right it does. Seems like I saw a post from sbritt-esristaff‌ where she explains why ESRI stayed with that default.  There may be a way to change the default locally, I'm not sure; perhaps she'll see this and let us know.

can't wait to retire....
ShanaBritt
Esri Regular Contributor

I wrote this technical article regarding the 'Match with no zones' geocoding option in the locator properties, which applies to ArcMap & ArcGIS Server/Enterprise 10.1+ and all versions of ArcGIS Pro. https://support.esri.com/en/technical-article/000011688 I had answered the same question in detail on the old community forums, but it is no longer accessible from what I can tell. I"ll need to poke around to see if they are backed up somewhere or not. https://community.esri.com/message/147473?commentID=147473#comment-147473 

RachelAlbritton
Occasional Contributor III

Shana - 

I've had to create a new address locator since writing this original post and I'm still getting 100% failed results. I have read your technical article. I have set Match to No Zones to Yes, and I removed/readded to the locator from the toolbar. What can be causing this?

Reply
0 Kudos
ShanaBritt
Esri Regular Contributor

Rachel:

Are you able to provide a screen shot of the locator properties (geocoding options, reference table)?

What do the input addresses look like? Are they just the street address (380 New York St) in a single field similar to the illustration in this help topic? http://pro.arcgis.com/en/pro-app/help/data/geocoding/about-geocoding-a-table-of-addresses.htm 

Reply
0 Kudos
RachelAlbritton
Occasional Contributor III

Thanks for the reply Shana. Yes, my input table looks like the illustrations sent. I have included a screenshot below as well as the locator properties.

Here is a screen shot of the properties

Input Table: 

I know this shows both street_address as well as the parsed address in the table. When setting up the geocoding process I am sure to choose the street address field (see below). 

I'm using the same input table as last year. This year the road geometry and info are exactly the same but the schema Data Types have changed. I can use the road data set with the previous years schema and it works fine. The new schema is needed for a new 911 system being implemented. I can put together a FGDB and attach in a zip file if that would be helpful, or just let me know if I should start a ticket with ESRI?

Thank you for your time.

Reply
0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

try changing the option "Match without house number" to 'NO' to test.

Reply
0 Kudos