ArcGIS 10.6 installs incorrectly

186
1
11-16-2018 02:03 PM
DerekOlson1
New Contributor

Hi.  I'm trying to use ArcGIS 10.6 on a Windows 7 Pro machine.  However, something is obviously missing from my installation.  When I start up ArcMap, I get a pop-up error message saying "Error in LoadPlanXML.  Error number: 5 Description: Value cannot be null.  Parameter name: type."  Otherwise, it appears to start up and work correctly, until I actually try to do anything.  Maps and data display normally.

When I attempt to use any of the tools in ArcToolbox, however, the execution always fails with error code 000210: Cannot create output.  Evidently, this is some type of non-specific error.  I have authorized and installed all extensions, so that's not the issue.  Basically, I can view and select layers and data on the map and in the table of contents, but I can't use any geoprocessing tools at all.  I tried uninstalling and reinstalling, as well as repairing the installation in Add/Remove Programs, with no luck.  It's very strange.

I originally upgraded from 10.1, but to make sure I didn't lose anything important, I found all the system directories with anything in their names related to ArcGIS or ESRI and moved them to a separate archive folder.  I then uninstalled 10.1 and installed 10.6, since you can't directly upgrade from one to the other.  I'm guessing that wasn't how I was supposed to do it, since I'm running into this problem now.  Any help would be much appreciated.  Thanks.

0 Kudos
1 Reply
CodyMarsh
Occasional Contributor

Hello Derek,

I would say that you may need to do a clean uninstall of ArcGIS Desktop as there may still be some registry entries leftover from the 10.1 install.

There is a very handy tool from Microsoft that can assist with the clean uninstall of ArcGIS Desktop.

*Disclaimer* This link will lead to Microsoft website. Any questions or issue with the tool will need to be directed to Microsoft as this is a non-Esri tool.

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed... 

That should help to clean up the registry on the system. Once uninstalled go ahead and install ArcGIS Desktop 10.6 once again to see if you are still receiving the error.

0 Kudos