Using Collector from Workforce

512
10
Jump to solution
08-21-2019 08:21 AM
BrianBulla
Regular Contributor

Hi,

I've created a Workforce project, and can see my Dispatcher and Worker maps from the projects Overview tab.  I am able to assign tasks through the Dispatcher map without any problems.

I'm using a Pixel 3 to run Workforce in the field.  I can see assigned tasks, but when I click on 'Collect at Assignment' to open up Collector, I get a "Map not found:  Make sure the map is shared with you." message come up.

It seems like my sharing permissions are setup correctly though, so I don't know what is going on.  Any ideas on things to try??

0 Kudos
1 Solution

Accepted Solutions
Kylie
by Esri Regular Contributor
Esri Regular Contributor

The accounts for Collector and Workforce are separate (meaning that signing in to one doesn't sign you in to the other), so make sure you are signed in to both apps with the correct accounts. For Collector, maps need to be either authored by you, or share with a group of which you are a member (not just shared with the organization). You might want to verify that the map is shared in that way. Also, the map opened by Collector is a different map than Workforce uses, so access in Workforce doesn't guarantee sharing is set up right for the map used in Collector. The project owner of your Workforce project configures what map Collector opens.

View solution in original post

10 Replies
Kylie
by Esri Regular Contributor
Esri Regular Contributor

The accounts for Collector and Workforce are separate (meaning that signing in to one doesn't sign you in to the other), so make sure you are signed in to both apps with the correct accounts. For Collector, maps need to be either authored by you, or share with a group of which you are a member (not just shared with the organization). You might want to verify that the map is shared in that way. Also, the map opened by Collector is a different map than Workforce uses, so access in Workforce doesn't guarantee sharing is set up right for the map used in Collector. The project owner of your Workforce project configures what map Collector opens.

View solution in original post

BrianBulla
Regular Contributor

Hi Kylie,

I have things working now.  Workforce was referencing a map to open that the user didn't have access to.  Thanks for the help!

LeandroLourenço_Bastos
New Contributor

Hi Kylie, 

 

I am trying to save a layer already configured in the collector, however when I capture the point it says "it was not possible to save its feature". This layer is the visualization layer. What can I do?

0 Kudos
CraigGillgrass
Esri Regular Contributor

Leandro,

Is this is a Collector issue or an issue with Workforce?

Are you trying to update the Workforce layer in Collector? 

Craig

0 Kudos
LeandroLourenço_Bastos
New Contributor

Hi Craig,

Yes I am trying to save the workforce layer assignments in the collector.

0 Kudos
CraigGillgrass
Esri Regular Contributor

Leandro, can you email the AWorkforce alias?  We can take this discussion to email to troubleshoot it.

Craig

0 Kudos
LeandroLourenço_Bastos
New Contributor

SureI'll be sending itThank you very much!

0 Kudos
LeandroLourenço_Bastos
New Contributor

SureI'll be sending it

Thank you very much!

0 Kudos
LeandroLourenço_Bastos
New Contributor

Craig,

Can you provide the email?

Thanks a lot

0 Kudos