Select to view content in your preferred language

Server Object Instance creation failed

1508
2
07-05-2012 05:13 AM
EduardoGonzalez
New Contributor II
I´m trying to add a Workflow Manager Server object but I´m having always the same error:  Configuration xxx.WMServer can not be started. Server Object Instance creation failed on machine xxxxxx.
The services is created, i can see it in my AGS Manager, but I can not start it....

I´ve tried it with the .jtc file in the arcgisserver folder, and also in other folders giving permission to SOC and SOM.

Some help?

Thank you!
0 Kudos
2 Replies
KevinBedel
Esri Contributor
Hi Eduardo,

Are you using OS authentication within your JTC file? If so, it will be trying to connect to the database as the SOC user. In this case, you either need to give permissions to the SOC user to access the database containing the Workflow Manager schema, or configure a JTC file using database authentication to be used by the server.
0 Kudos
EduardoGonzalez
New Contributor II
Hi,

unfortunately I still have the same problems when setting up the Workflow Manager Service

I recreated the empty personal ArcSDE (name WFX) using ArcCatalog
Then I created a "WFX" database login within this database and assigned the "Sysadmin" role (maybe too much privs) in addition to the public role
Then I created a WFX schema within the WFX database
Then I created a WFX user within the WFX database who owns the WFX schema and which is related to the login WFX
Then I assigned the Role ESRIAdmin and db_owner to the WFX database user
As result WFX login, WFX db user and WFX schema are strongly related

Then I set up the Workflow Manager schema with default configuration, 100MB MAXBLOBSIZE without any problems with the Post installation using the database authentication (login user WFX). All tables were created in the WFX schema

Also the Workflow Manager Server could be created successfully with ArcCatalog

When I now try to create the Server Object using the JTC File from the post installation (with WFX db user authentication) I still get the same error message. (The Server object is created but I can not start it).

Thanks!
0 Kudos