Select to view content in your preferred language

Linked properties and domains - supported?

05-27-2012 12:37 PM
Occasional Contributor III
Hi There,
I'm trying to use a domain on a linked property (1:m) however seeing this behaviour:
In the job properties we can set the domain on the field just fine as per related props (1:1)
However when trying to add a record to our job and entering a value into the table a) we don't get a domain dropdown and b) we do get:


Note this doesn't stop us updating the field, but we don't get the normal domain behaviour.

0 Kudos
3 Replies
Esri Contributor
Hi Fraser,

Yes, this should be supported. What type of field is your domain using? is it a Text field? When does that error message occur? As soon as you try to add a row/view an existing row, or when you click Save?

As well, what SP do you have installed? There were some changes to the way this works at SP4 that may resolve the issue.
0 Kudos
New Contributor
Fraser originally posted the question on my behalf, here is the response to how the error is presented

The Domain

The Linked Property Table is as follows

The Linked Property Setup

We right click on the linked property grid, click add
We are presented with a new row
The row does not show dropdown options
If I type into a field/column and enter I get the error
0 Kudos
Esri Contributor
Hi David,

I have been able to reproduce this issue and have determined the cause of it. The issue is that when configuring the linked properties for the job type (screenshot 3), if you just check the field in the tree view on the left-hand side without actually clicking on that node, it does not correctly set the display type. This means that it is displaying this field as a Text Field. However, when it this tries to validate the field, it sees it is really a domain and tries to validate it as such and fails. This causes the error message you experience.

You should be able to resolve this issue by editing the job type, selecting the field in the tree view, confirming that it shows "Domain" as the Display Type, and clicking OK to save the update. I will also log a bug in order to resolve the underlying issue in future releases.
0 Kudos