GPTool that's work as LauchGPTool and doesn't work as ExecuteGPTool

10-08-2013 09:51 PM
New Contributor III

I tried to set up a step to create a folder. 
I used the GP tool: "Create Folder".

When I defined the step as LaunchGPTool it's worked as I expected and created the folder.
When I defined the step as ExecuteGPTool, the step worked but didn't create the folder.

The computer configuration is:
Win 7,
ArcGIS + WMX 10.1 sp1
Oracle 11G, SDE 10.1

would greatly appreciate it if you can help me.
0 Kudos
3 Replies
by Anonymous User
Not applicable
Hi Hadas,

Could you provide the arguments you have input for the ExecuteGP tool to create the folder?

0 Kudos
New Contributor III
Thanks Michael,

We got an announcement from ESRI that this problem is a known bug. We found a way to bypass the bug, by using a PYTHON script instead.

Hadas Sagi
0 Kudos
Occasional Contributor

ExecuteGPTool custom tool did not work but a sample, similar to ExecuteGPTool, is available in the installation directory . Building the .Net solution makes the custom tool appear in the custom tool selection window. And this works fine.
0 Kudos