WebApp Builder Edit Widget - move point and it does not "stick"

2267
4
02-18-2016 08:15 PM
PaulDoherty2
Occasional Contributor III

Anyone else with this problem? See ArcGIS Idea page and vote: https://shar.es/14FuhD

Why won't the point just stay where I put it????

A member of my organization pointed out a shortcoming in the Edit widget that could probably be easily fixed.

Here is an excerpt from the tutorial I built that explains the workflow. It seems step 3 is not intuitive at all. Shouldn't there be a "done" button or some way to make the point "stick" to the second location without the tricky nuance of having to click somewhere else on the map?

We can also move the location of a mission using the Edit Missions application. If you have exited the Edit widget - open it again by clicking on the Editor icon as shown in the step above.

1.    Once the Edit widget is open, click on the mission / point that you would like to move. The pop-up box should open and when you hover over the point, a little hand icon should appear. You may need to zoom out in order to move the location a far geographic distance from the original point. 

2.    Move the point using the little hand to your desired location.

3.    IMPORTANT - once you have moved your point - click anywhere else on your map to confirm the location. If you zoom out, pan, or close the editing widget the point will return to the original position.​

- See more at: https://c.na9.visual.force.com/apex/ideaView?id=087E0000000kBhD&returnUrl=%2Fapex%2FideaList%3Fc%3D0...

Capture.PNG

4 Replies
BillAddison
New Contributor II

Were you able to rectify this problem?  I am having the same issue and am out of ideas.

0 Kudos
PaulDoherty2
Occasional Contributor III

Bill - I believe Esri is working on this issue, but in the meantime I just provided instructions to my users. 

Paul J. Doherty, PhD | Chairman SAR Working Group

National Alliance for Public Safety GIS (NAPSG) Foundation

Tel. 202-895-1711 | Email pdoherty@publicsafetygis.org

www.napsgfoundation.org  | @napsgfoundation  | USNG 18SUJ1926814427

0 Kudos
BillAddison
New Contributor II

Thanks for the reply Paul. I just got through a session with tech support and here is what I discovered.

1. They were as stumped as me… LOL

2. After moving the point, click on the map and make sure you see a progress bar in the edit window.

I could have sworn I tried every sort of keystroke/mouse sequence, to include this one, but for whatever reason it does seem to be working. Here is the link I was sent…

http://support.esri.com/en/bugs/nimbus/QlVHLTAwMDA5MjEyNw==

PaulDoherty2
Occasional Contributor III

Ok that is great news it is in their development plan to fix.

0 Kudos