Problem with specify my wab developer url and app id

3730
6
Jump to solution
06-03-2016 02:29 AM
RolandGliba
New Contributor III

After setting my org url and provide the app id in the browser I got the green sign after that I accessed my account then redirect the url to specify the url of my arcgis org again and then  I do this again and again. Any idea? Thanks

0 Kudos
1 Solution

Accepted Solutions
RolandGliba
New Contributor III

Problem solved with a new AGOL account....I don't know what is the different between them.

View solution in original post

6 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Roland,

Take a look at and follow the steps carefully in Tips and Observations for getting Web AppBuilder -  Developer Edition Installed

another very detailed version for installing and working with custom widgets cane be found Installing Robert’s Enhanced Search Widget for the Web AppBuilder

for help finding and keeping up with all the customer widgets and other news, might want to look/bookmark Web AppBuilder Developer Edition - Customization Resource List​    Links to the above blogs and many other resources are included in my blog...messy, but lots of info there and I try to keep it up to date.

RolandGliba
New Contributor III

Rebecca,
First, thank you for the help.
I payed attention to all steps and hints in the instructions. My url is perfect I'm sure because when I use wrong url directly the message is an invalid response and now in this case with the correct urls and appid-s I can step further to approve the AGOL account after that it redirects me the click continue again with my org name except the app id row. Nothing helps me neither steps and hints. If I delete the json file and give the reregistered app's id in the row the result the same. I have tried everything from anothor two pcs as well with the same result so I guess the problem is with the AGOL settings or somekind of stuffs what I didn't know to exist Pls help me to solve this. Thank you

0 Kudos
RolandGliba
New Contributor III

Problem solved with a new AGOL account....I don't know what is the different between them.

View solution in original post

RebeccaStrauch__GISP
MVP Esteemed Contributor

Glad you got it working Roland.  I'll add this as another tip in the document....just in case others have this issue.  This might not be a solution for others (since named users can be limited) but might be a troubleshooting tool.

It would still be nice to figure out "why", that is, a permission problem or just a hiccup for that username.....but once it's working....

0 Kudos
RolandGliba
New Contributor III

I guess I did everything well but still not working. When I use the URL with my machinename and domain name I got 400 error url redirect problem and when I use it with localhost url I take the appid in the row access my username and pass to agol then redirect again to the providing page to give org name and app id. Where could be the problem? My url-s are good. I don't understand it.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I would start the registration on AGOL over again, and again, make sure to pay attention to all the instructions in Step 3...including the hint to make sure you get the domain name if that is needed, and the link to WAB redirect_uri error 400 ...again

Also, might want to make sure you have both http and https, and that your machine actually has access to AGOL.

0 Kudos