How do I make the panel from a header widget open on the left side of my screen?

306
4
Jump to solution
03-06-2020 11:09 AM
by Anonymous User
Not applicable

By default all of the widgets I have in my header open a panel on the right side of my screen. How can I configure where the panel opens? Ideally I would like the panels to open just below the default location for the search widget (I do not have any widgets below the search widget).

I am working in WAB 2.8.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Andrew,

  In the apps config.json find the widgetPool section and change the panel > position > top to 45 and panel > position > right to left: 55

View solution in original post

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Andrew,

  In the apps config.json find the widgetPool section and change the panel > position > top to 45 and panel > position > right to left: 55

0 Kudos
by Anonymous User
Not applicable

Robert,

I was able to move the panel to the left side of the screen by changing right to left, but the top and bottom don't seem to change as I change the values. I should mention that I was given a custom theme to work work with ( a minor alteration of the foldable theme) is there likely to be anything in the theme files I need to change that could be overriding the top and bottom values? 

  },
  "widgetPool": {
    "panel": {
      "uri""themes/MAATheme/panels/FoldablePanel/Panel",
      "position": {
        "top"45,
        "left"55,
        "bottom"40,
        "zIndex"5,
        "relativeTo""map"
      }

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Andrew,

   There is very likely some custom code written in your custom theme then, because when I have the suggested changes in a default foldable theme it work fine. You may want to look in the PanelManager.js and the showPanel function that is the likely location of your custom themes change that would override the config.json top setting.

by Anonymous User
Not applicable

Thanks Robert, must be the the custom theme, I will check those suggestions. 

0 Kudos