ArcGIS Online WebApp Builder - Services on own Server

4956
15
Jump to solution
04-27-2015 04:54 AM
ThomasSteudel1
Occasional Contributor

Dear Community,

i have a question regarding the WAB.

I configures a WebMap with the WebApp Builder via ArcGIS Online.

The services within the Map are hosted on ower own server. The thematic layers are visible when i configure the Maps.

Now the problem:

I scanned the QR Code, to see if the responsive design is working.

After scanning i had to login into AGO (because the map is not published (free to all) yet).

On the mobile device with internet access (not in WLAN mode), the map is loading aswell as the map layout.

Problem: The thematic layers (which are published on our server) are not showing up (also the layerlist is empty) - means the layers are not even loaded into the application.

Question: Is there any setting to be done from side of our IT Department (Port- or Proxy Setting?).

Thanks in advice,

am a AGO "beginner".....

Thomas

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

It looks like your services are not externally accessible.  You can check this by trying to access your REST services directory on your mobile device, i.e.:

http://servername/arcgis/rest/services/WK_Test/MapServer/0

IT will need to create a Fully Qualified Domain Name (FQDN), i.e. www.esri.com, for your web server.  You will then be able to access your services externally using the FQDN. Ex:

http://www.esri.com/arcgis/rest/services/WK_Test/MapServer/0

View solution in original post

15 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Thomas,

Are your ArcGIS Server services accessible externally?  That is, can you access them outside of your network/firewall?

0 Kudos
ThomasSteudel1
Occasional Contributor

Hi Jake,

sorry for the late answer.

How can i figure out if my services (which are stored on ouer organisation server) are accessible externally?

I tried to load the webmap again and the error messages pops up (the application is visible, the serive not:

"Timeout exceeded [url: http://localhost....../arcgis/rest/services/WK_Test/MapServer/0]"

If it is not externally visible, what has to be done? Where do i have, or where does the IT have, to change the settings? I am sorry, i do not find a "walk through" within the help section of esri or AGO.

Thanks for your help and best regards,

Thomas

0 Kudos
JakeSkinner
Esri Esteemed Contributor

It looks like your services are not externally accessible.  You can check this by trying to access your REST services directory on your mobile device, i.e.:

http://servername/arcgis/rest/services/WK_Test/MapServer/0

IT will need to create a Fully Qualified Domain Name (FQDN), i.e. www.esri.com, for your web server.  You will then be able to access your services externally using the FQDN. Ex:

http://www.esri.com/arcgis/rest/services/WK_Test/MapServer/0

StanMcShinsky
Regular Contributor

If you are running portal then you can host in all internally and do not need a FQDN just the name of your server.

-Stan

ThomasSteudel1
Occasional Contributor

Hi Stan,

thanks for your answer. We though about hosting the serives within the portal for ArcGIS (online hosting) but its not possible because of end user agreements which we signed with our partners. The services and the data can only be stored on our own servers. Also we crated already alot of application for Flex Viewer and hosted all the services and also the data on our servers. To migrate between the projects its seems the easiest way, not to change the paths or location of the services.

Best regards and thank you,

Thomas

0 Kudos
StanMcShinsky
Regular Contributor

Thomas,

When I mentioned using portal I was meaning to use the locally hosted Portal that is behind your firewall. You would have no need to have online hosting. It ties directly to your ArcGIS Server and it manages your map services. Imagine it as having your very own ArcGIS online just for your organization. Everything from data storage to map services will be on your own servers.

Portal for ArcGIS Server Extension | Overview

With 10.3 you now have access to install Portal for free with ArcGIS Server Standard or Advanced.

-Stan

0 Kudos
PriyaRam
New Contributor III

Hi Stan - I have a similar situation like Thomas migrating from Flex to ARCGIS Javascript. I used the WAB in my local machine and created a sample template with just the basemaps and few widgets (no operational layers) using the ARCGIS online account and downloaded the source code and dropped it into my IIS server where ARCGIS 10.3 server(no portal) is installed.

so that I could add the operational layers and play around a bit.

I have a basic question, will the WAB work in ARCGIS 10.3 or do I need to install the Portal Extension .

If Portal is not needed, should I sepcify the application URL in the config.json . like http://<servername>/web-context/index.html. Am I headed in the right direction ?

Please advise.

-Priya

0 Kudos
StanMcShinsky
Regular Contributor

Priya,

WAB will work just fine with 10.3. Are you using the developers version? Depending on how you want your set up will depend on if you will need portal or not.

-Stan

PriyaRam
New Contributor III

Yes, I'm using the Developer version. I'm getting a blank page, when I run the app from ARCGIS 10.3 Server. However, when I run locally

on my machine. by starting node.js, I can see the blank template with widgets in it, logged into the ARCGIS online account.

Portal URL I used : wave.maps.arcgis.com

Host the app in ARCGIS 10.3 server without portal

I understand, I have to modify the confg.json. I donot have any proxy set up . what are the mandatory keys that needs to be filled in this scenario, .Does it need portal URL and app ID, itemid , that needs to be filled in this scenario ? Any blogs or document , that you can direct me to, for this particular scenario ?

Thanks..

Priya

0 Kudos