create a custom in panel widget problem

4706
12
02-05-2015 05:33 AM
LeeCollier3
New Contributor

Step 5 in the create a custom in panel widget

https://developers.arcgis.com/web-appbuilder/sample-code/create-custom-in-panel-widget.htm

just makes no sense as webapp and sample-configs as well as config-demo.json do not exist.

Does anyone know what the URL should be to test the custom widget

Thanks

0 Kudos
12 Replies
TimWitt2
MVP Regular Contributor

Lee I had the same issue.

Instead of testing it their way, I just tested it in an actual app.

0 Kudos
LeeCollier3
New Contributor

I originally ignored that step and tried to test it in an actual app but just code not "see" the custom widget in app builder.

Have edited the config.json but it still is not visible

0 Kudos
TimWitt2
MVP Regular Contributor

Lee,

in your client\stemapp\widgets folder is a file called .repoignore, delete that file and your custom widget should show up.

Tim

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Julie Powell

Moxie Zhang

Zhifang Wang

Jianxia Song

WAB has been released for several months now and the developing a custom widget documentation errors have been plaguing GeoNet ever since. This is one of MANY such posts where end users are following the instructions for "create custom in panel widget" and the steps outline files that do not exist in the released version. As this is just a documentation issue can we not get this fixed before the next release?..

LeeCollier3
New Contributor

Have copied the "MyWidget" to the \stemapp\widgets folder and edited the \stemapp\config.json file is there anything else that I need to do?

0 Kudos
Jianxia
Esri Regular Contributor

This is a known issue. The sample-configs folder will be added back in the next release. The workaround is to make a copy of config.json file, and name it “config-demo.json”, then perform all the operations in the steps referring to config-demo.json with the new file. To see the changes you made in the custom widget,

replace the url in the sample

http://[your host name:3344]/webapp/?config=sample-configs/config-demo.json

with new url:

http://[your host name:3344]/webapp/?config=config-demo.json

Thanks,

Jianxia

JunshanLiu
Occasional Contributor III

I upload the files that are forgot to add into 1.0 release. Could you put them under stemapp and have a try?

This is the file:

demo config is missed patch for 1.0 release.

0 Kudos
ZhifangWang
Esri Regular Contributor

Thanks for reminding, it's supposed to be fixed in next release.

0 Kudos
LeeCollier3
New Contributor

Thanks for the reply's, apologies for the delay in getting to this have been struggling with implementing RESTful WMTS in flex viewer.

Now have the Mywidget sample working. Thanks to Junshan for the patch this enabled the instructions to be followed a lot better and had the widget working through

http://[your host name:3344]/webapp/?config=sample-configs/config-demo.json

in no time, although this page loaded as a blank page to start with and needed a click to load the map????

The final hurdle of having mywidget in the app builder to choose was solved by:-

Copying the widget into the widgets folder as stated.

But then the manifest.json of the sample was causing the trouble so copied it from another widget and edited it.

Also added the widget to the config.json.

Thanks again for the help.

0 Kudos