Define Features as Container-Features

527
5
Jump to solution
09-14-2022 12:47 AM
Luca_Schikowski
New Contributor III

Hello there,

I think this is pretty basic stuff, but I am struggling here for a while. 
I got 2 assetgroups in my structure line feature class: routes and pipes.

I want to define the route-features as container for the pipes. How do I get this done?

Thanks in advance and have a nice day 🙂

Luca

0 Kudos
1 Solution

Accepted Solutions
G_Dillenger
New Contributor II

Before you do anything:
1. Disable Topology
2. Connect to DB; not the service.

When ready:
1. Set Association Role

G_Dillenger_0-1663144194584.png

 Replace Conduit with your Routes

 

2. Add Rule of the Containment type 

G_Dillenger_1-1663144467065.png

Forgive my "hand writing":

 

3. Use the Modify Associations Tool to contain pipes within routes.

G_Dillenger_2-1663144580430.png

 

 

View solution in original post

5 Replies
G_Dillenger
New Contributor II

Before you do anything:
1. Disable Topology
2. Connect to DB; not the service.

When ready:
1. Set Association Role

G_Dillenger_0-1663144194584.png

 Replace Conduit with your Routes

 

2. Add Rule of the Containment type 

G_Dillenger_1-1663144467065.png

Forgive my "hand writing":

 

3. Use the Modify Associations Tool to contain pipes within routes.

G_Dillenger_2-1663144580430.png

 

 

Luca_Schikowski
New Contributor III

Hey, thanks for the quick reply. 

Somehow I am not able to choose my routes in the modify associations pane. 

Luca_Schikowski_0-1663147549859.png

I am only able to select the "Unknown"-Asset group. Is this a known issue?

0 Kudos
G_Dillenger
New Contributor II

That is stating what you selected. It looks like you selected a feature that has an unknown asset group.

Sometimes, if I selected something previously the menu here does not update all the time. You could remove all selections and use the Add features button to select the proper.

0 Kudos
Luca_Schikowski
New Contributor III

The feature I selected had the asset group 'route'. I dont know why its not working. But I "fixed" it using subtype group layers. Now I got the correct asset group, sadly I also got an unknown asset type even though it is filled with data. I will try to figure out where the problem is.

Luca_Schikowski_0-1663159502172.png

"Trasse" means route.

0 Kudos
Luca_Schikowski
New Contributor III

Is there a way to automatically create those containment-associations? I got around 500 pipes in my Utility Network and this is only for test purposes. 

As far as I know, I have to manually select the features and set the containment association. There is surely a more efficient way to get this done, right? Maybe based on attributes?

0 Kudos