ArcGIS Pro 2.5: Which utility network rule allows connecting line with line anywhere along edge?

1087
12
Jump to solution
05-21-2020 10:35 PM
JamalNUMAN
Esteemed Contributor

ArcGIS Pro 2.5: Which utility network rule allows connecting line with line anywhere along edge?

 

For example, in the screenshot below, I wanted a rule that allow L2 to be connected to L1 anywhere along its edge without the need to have junction, device, or assembly. How this rule can be configured?

In the 3rd screenshot, despite the fact that there is a connectivity rule between L1 and D1, plotting D1 along the L1 edge considers as rule violation!

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
1 Solution

Accepted Solutions
ChristianBecker1
New Contributor II

Hi Jamal

Next issue could be to check the Edge connectivity. You can check it with the tool, but you can only change it if you disable the Network Topology.

From the toolbox select the "Set Edge Connectivity" tool. Select the UN, Domain and line Feature Class for the L1 line asset group and type.

There are 2 options for the edge connectivity.

a. Any Vertex (this option should be selected)

b. End Vertex

And run the tool and Enable topology again

View solution in original post

12 Replies
PaulLeBlanc1
Esri Contributor

You cannot. If two edges are connected at a vertex, they must have a point feature also coincident if the edges have different asset group & asset type.

JamalNUMAN
Esteemed Contributor

Then why I’m getting point and line errors as a device (D1) is plotted along (L1) edge despite the fact that there is a junction-edge connectivity rule between L1 and D1

 

What could be the issue here?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
PaulLeBlanc1
Esri Contributor

Looks like D1 is midspan. If you identify the error, it should give you more information. It's difficult to make assumptions about your model and errors...

Set Edge Connectivity—Utility Network Toolbox | Documentation 

JamalNUMAN
Esteemed Contributor

Not sure what’s meant precisely by midspan?! How this term is differentiated from midpoint?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
DanPatterson
MVP Esteemed Contributor
JamalNUMAN
Esteemed Contributor

Here the issue is different. The rule between line (L1) and device point (D1) is configured, nevertheless, errors are identified

 

What might be the reason?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
ChristianBecker1
New Contributor II

hi Jamal NUMAN

Looking at the last Picture you sent I would conclude the following:

The line must have a vertex at the same spot as the device/junction is set. They must be coinsident (X,Y,Z).

The "Midspan Error" on line can mean "between the vertices".

Working with the rules:

If you have the rule and set the device/junktion a vertex is created on the line.

If you have the device and the line and make the rule no vertex is set on the line.

See the link Paul LeBlanc‌ sent. first lines reads:

There are two locations where point features can connect to lines: an end point and a midspan vertex. Each asset type in the domain network is set with a default edge connectivity setting.

Hope this will help you.

JamalNUMAN
Esteemed Contributor

Thanks Christian.

 

In the screenshot below, the device D1 is digitized on top of a vertex of Line L1, nevertheless, the “midspan connectivity not allowed” error persists to exist.

 

What other issues might I need to check?

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
ChristianBecker1
New Contributor II

Hi Jamal

Next issue could be to check the Edge connectivity. You can check it with the tool, but you can only change it if you disable the Network Topology.

From the toolbox select the "Set Edge Connectivity" tool. Select the UN, Domain and line Feature Class for the L1 line asset group and type.

There are 2 options for the edge connectivity.

a. Any Vertex (this option should be selected)

b. End Vertex

And run the tool and Enable topology again