Select to view content in your preferred language

Apply Assets Package Error

1061
7
Jump to solution
07-25-2023 04:22 AM
FaisalAl-Yaseein
New Contributor II

Hello Esri Community,

I hope this post finds you well. I am facing a problem with Utility Network while working on the water utilities data for Mosul City. I have successfully migrated the data using data loading tools to the water utilities foundation schema. After this, I staged the water utilities, but when I attempted to apply the assets package from the toolbox, an unexpected error occurred, hindering further progress.

I would greatly appreciate any insights or suggestions on why this error might be occurring and how I can overcome it. If anyone has encountered a similar problem or knows potential solutions, your guidance would be immensely valuable.

The error message I encountered is as follows:

Apply Asset Package
=====================
Parameters

Asset Package C:\MSc\MSc_Thesis_GIS\Project\ArcGISProject\MSC_Mosul_Utility_project\WaterDistribution_AssetPackage_Change.gdb
Domain Networks to apply Structure;Water
Input Utility Network C:\MSc\MSc_Thesis_GIS\Project\ArcGISProject\MSC_Mosul_Utility_project\WaterDistribution_AssetPackage_Change.gdb\Mosul_Utility_Network_1\Mosul_Utility_Network
Load data INCLUDE_DATA
Calculate Spatial Index and Analyze ANALYZE
Output Utility Network
Configurations to apply Attachments;'Isolation Tier';'DMA Tier';'Pressure Tier';'Cathodic Protection Tier'
Rename using
Post Process NO_POST_PROCESS
=====================
Messages

Start Time: Tuesday, July 25, 2023 2:20:16 PM
ArcGIS Pro 3.1.2.41833
untools 3.1.0
Executing from ArcGIS Pro, 6 map(s), activeMap = True
Parallel processing enabled: 6

Asset Package schema version: 2.7
A python error occurred.
EXCEPTION
Traceback (most recent call last):
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\common\wrappers.py", line 159, in wrapper
f = func(*args, **kwargs)
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\gptools\tools.py", line 609, in run
ap = ap_constructor(
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\gptools\tools.py", line 53, in ap_constructor
ap = AssetPackage(
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\utility_network\ap.py", line 87, in __init__
self._properties: dict = self._initialize(kwargs.pop("cache", None), **kwargs)
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\common\wrappers.py", line 425, in wrapper
result = func(*args, **kwargs)
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\utility_network\ap.py", line 123, in _initialize
data = self._validation.validate_all(asset_package=self)
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\validation\validate.py", line 1117, in validate_all
data = self._virtualize_un(asset_package)
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\validation\validate.py", line 1029, in _virtualize_un
xml_un = s.main()
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\utils\ap_to_xml.py", line 1709, in main
self.add_domain_networks()
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\utils\ap_to_xml.py", line 715, in add_domain_networks
self.set_values(
File "C:\Users\A971891\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\untools\utils\ap_to_xml.py", line 338, in set_values
element.find(k).text = str(v)
AttributeError: 'NoneType' object has no attribute 'text'
Failed to execute (AssetPackageToUtilityNetwork).
Failed at Tuesday, July 25, 2023 2:20:42 PM (Elapsed Time: 25.48 seconds)

 

FaisalAlYaseein_0-1690283886646.png

 

0 Kudos
1 Solution

Accepted Solutions
MikeMillerGIS
Esri Frequent Contributor

It looks like there is a UN in the Asset Package.  There are known issues with this.  You need to remove the UN and the FeatureDataset.  

View solution in original post

0 Kudos
7 Replies
MikeMillerGIS
Esri Frequent Contributor

Could you share a schema only asset package(run change Asset Package Spatial Reference) and the ap_workspace folder that was created?  We do not need data.  

0 Kudos
FaisalAl-Yaseein
New Contributor II

I already did for the target schema, which result in new gdb with the same schema and no data with the projection that we need. when I run the staging of the utility network, it produced a new data set. the next step from references is to apply assets package which its stopped me

 

FaisalAlYaseein_0-1690293864629.png

 

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

It looks like there is a UN in the Asset Package.  There are known issues with this.  You need to remove the UN and the FeatureDataset.  

0 Kudos
Ariggs
by
New Contributor III

Hi Mike,

I'm also trying to run Apply Asset Package with pre-existing data. I exported my Utility Network to an asset package, modified that asset package with the D_configurations and D_rename tables, and am following the Solutions workflow for creating a new enterprise geodatabase and running Stage Asset Package and Apply Asset Package. Apply Asset Package is failing with the following error: 

AttributeError: 'NoneType' object has no attribute 'text'
Failed to execute (AssetPackageToUtilityNetwork).

 Is there some other workflow I should be following or step I have missed in order to run Apply Asset Package with an existing UN in the asset package? Or some other method of creating a new Utility Network with the data of an old one?

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

Can you post a screen shot of the error?  What version of ArcGIS Pro and untools are you using?

0 Kudos
IvanDImitrov
New Contributor II

How is that - to remove UN?
If we want to apply the asset package to a .GDB, we need some features, right? 

 

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

The asset package A_, B_ table represent all the properties of the Utility Network and are used to construct one.  There should not be a utility network in the asset package.

0 Kudos