Apply Asset Package failure

347
3
03-23-2022 05:26 AM
moebra
by
Occasional Contributor

Dears I have an issue with Apply Asset Package script (tool) while working on Utility Network:

A.Messages

ArcGIS Pro 2.9.2.32739
untools 2.9.1
Executing from ArcGIS Pro, 2 map(s), activeMap = True
Parallel processing enabled: 6
Asset Package schema version: 2.4

B.Erros:

ERROR 000110: Electric Generation Station does not exist
ERROR 002824: Something went wrong in Polygon/Polyline simplification.
Failed to execute (SetSubnetworkDefinition).
ERROR 001958: No valid asset group was found.
WARNING 000952: Failed to execute (AssignDomainToField).El_Saket_1-1648037295443.png

My environment:

Pro 2.9.2 
Enterprise: 10.9.1 (with UN extension) with ArcGIS solutions Deployment 10.9.1 from myesri.com.
PostgreSQL DB: 12.4
untools: 2.9.1 (Last version)
dltsolutions: 2.4 (Last version)  & (v2.7.1)

I have tried the following scenarios and none of them works:

1- Upgrade dltsolutions to last version (2.7.1).
2- Downgrade Pro to 2.9.0 & untools 2.9.0 & dltsolutions 2.7.1.
3- Applied Upgrade Asset Package tool on the input Gdb.

0 Kudos
3 Replies
MikeMillerGIS
Esri Frequent Contributor

I am not sure what is going on here.  Something is not being applied correctly.  Did you start with a new postgres gdb or was this an existing GDB?  I see you have maps open, we have seen where these create locks on the Utility Network and cause corruption.  Can you close all the maps, restart pro and apply the asset package to a new Postgres database?

0 Kudos
moebra
by
Occasional Contributor

Hi @MikeMillerGIS , thanks for your reply,

I have a File gdb with UN Schema, and want to convert (Load) it into Enterprise gdb, and I follow some ESRI's steps which starts with these untools (Scripts):

1- Stage Utility Network.
2- Apply Asset Package. (the Issue).

Also I downgrade ArcPro for second time from 2.9.0 to 2.6.0 with ([untools: 2.6.0] & [dltsolutions: 2.7.1]) and issue still exist.

and about your workaround (re-open project without layers) I tried I also have tried it.

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

If you do the same process to a Mobile or File GDB, does it succeed?  In the asset package folder, there is a ap_workspace folder, can you send me the gp log file?  Could you send a schema only asset packge or UN that I can try to repo the issue? mmiller@esri.com

 

 

What version of postgres are you on?

 

0 Kudos