Select to view content in your preferred language

webform issue after After Survey 123 September 2021 update: Create web form' enabled. Error: Missing .webform file

7328
34
Jump to solution
09-24-2021 05:49 AM
WetherbeeDorshow
New Contributor III

Since the September 16 update, several surveys no longer work in the webform, even after rebuilding and republishing the survey using the latest version of Survey 123 Connect.

We get this error - 

This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file.

Press here to try to open this survey in Survey123 field app (installation required).

Interestingly, when I look at the webform that gets created successfully during the publishing process, the content of the .webform file is as follows:

{
"error": {
"code": -1,
"details": [],
"message": "Error: [object Object]"
},
"success": false
}

 

This issue appeared immediately after the September 16th update, prior to any efforts to republish or change the form.

Thanks!

34 Replies
by Anonymous User
Not applicable

No work around yet...

Quick, everyone check your downloads folders on all computers for previous versions. We also need to start a repository of old versions of software for emergencies like this. 

JamesTedrick
Esri Esteemed Contributor

Hi all,

To provide an update on this.  As mentioned in the solution, there was an issue present that was due to the mis-processing of an audio question.  Subsequently, we have been alerted to a similar issue with the use of an external choice list.  This can be worked around by using the select_one_from_file alternative, which is more flexible in data management than the external choice list.   We plan to correct this issue (which is in the Survey123 form processing API, not Survey123 Connect) as soon as we are able to.

HaroldHerrera1
Occasional Contributor

Hi James.

Can you confirm "Select_one_from_file" alternative works in webform? A few months ago, after UC2021,  I did a test updated the file data on my survey, using "Select_one_from_file", It works in the mobile app, but in the webform not. For this reason we discard using this option due to the data update

Do you know if It's fixed?

0 Kudos
MJBiazar
Esri Contributor

Hi @HaroldHerrera1 ,

I was able to confirm that using select_one_from_file instead of select_one_external does not reproduce the error and works as expected in both field app and web app. Attached is a sample survey that you can use to test this workaround.

by Anonymous User
Not applicable

Hi James,

We're running into the same issue of publishing a survey using an existing feature service (generated from an SDE) and running into the missing webform issue. We are not using any audio or external choice list questions. Our Survey 123 Website is 3.13 and so is the Connect. Any idea why?

 

0 Kudos
HeatherBerg1
New Contributor

We are having a similar issue to gganesan using a feature service published from SDE. No audio files or external choice list questions. Using Connect v3.12.232. Any updates on this issue?

0 Kudos
Kanin
by Esri Contributor
Esri Contributor

Hi all,

Based on this blog: What's new in ArcGIS Survey123 (December 2021) - Esri Community

BUG-000144749 Survey with external selects published from ArcGIS Survey123 Connect cannot be accessed in the web app, and returns the following error message, "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

The defect above has been fixed in the December 2021 release of Survey123 website. Please do see if the issues has been resolved in your survey forms.

Kudos to @IsmaelChivite for the updated release of Survey123!

Best regards,
Kanin 

If this answer solved your question, please mark it as "Accept as Solution" to help others who have the same question.

by Anonymous User
Not applicable

Thanks @Kanin. One thing I noticed is this doesn't work automatically. I had to republish all my surveys for the correction to work. Others might have to do the same.

0 Kudos
RainbowUnicorn
New Contributor III

Houston, we still have a problem.  

Getting the same error after making a few minor tweaks to a Survey123 template.  

...if Survey123 were a horse, it would be at the glue factory by now.

0 Kudos
MJBiazar
Esri Contributor

Hi @RainbowUnicorn , 

I have a few questions to have a better understanding of the environment of your issue:

  1. Are you working in ArcGIS Online or Enterprise?
  2. Are you experiencing this issue after republishing a survey that was working before? If so, what changes did you make? 
  3. Do you get the same error if you publish a copy of this survey? (make sure that "Create web form" is enabled when publishing)

 

If possible, can you share the XLS form for your survey? 

 

Thanks,

MJ

0 Kudos