Web Form Error - An item with the same key has already been added

378
3
04-01-2020 12:55 PM
joshahmann
New Contributor

Hi All, 

I have published a survey through Connect and have a web app setup to link to the web form. I have the link setup to edit existing data and add records to a related table. I am able to update an existing record and add a related record but if I try to enter two related records I get the following error:

"Failed to submit - An item with the same key has already been added."

Also, if I open a record in the web form that already has a related record and try to edit either the main record or the related record, I get the same error when I hit submit. 

The feature class and the related table are linked using a GUID. I have no problem adding related records using my web app, its only Survey123 that fails. 

Any help would be much appreciated. 

0 Kudos
3 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Josh,

Apologies for the delay.  For this scenario, it would be helpful if we had a few more details.  Is this using an existing feature service or a feature service created by Survey123 Connect.  The failure to submit occurs only when there are more than 1 new repeat records, correct?

0 Kudos
by Anonymous User
Not applicable

Hi James,

I am also getting this error mine is probably just because I'm editing a data within my repeat table. Is it still not supported in Survey123 web app? 

0 Kudos
MaryEllen_Perko
Occasional Contributor II

Hi.  Did anyone ever get an answer to this?  We're running into the same problem.  Thanks.

0 Kudos