SVG image-map not working in browser

722
2
Jump to solution
02-15-2022 04:45 AM
LaoiseDillon
New Contributor

Hi there. Wondering if anyone can help me with this.

I followed instructions from an esri community blog to create an svg and image-map in survey123. My image-map is working fine on Survey123 Desktop (as an unpublished survey) and I am able to select multiple regions on the map. When I publish the survey and access it from the browser, it reverts to a non-selectable image with the choices in a list below (link here: https://arcg.is/1eemP9 ). Wondering if anyone can point me in the right direction to fixing this issue? Thanks.

Also, it may be relevant that the svg I created is very large (map of the worlds oceans) and has over 3,000 selectable areas - could this affect its functionality in the browser? 

0 Kudos
1 Solution

Accepted Solutions
Jim-Moore
Esri Regular Contributor

Hi @LaoiseDillon 

The image-map appearance is not supported in the Survey123 web app. Please see documentation on image-map here and here, and also this blog post. You could raise this as an enhancement request with Esri Support, or up-vote this ArcGIS Idea and add your comments to it:

Select options of image-map to work in internet br... - Esri Community

Best, Jim

View solution in original post

0 Kudos
2 Replies
Jim-Moore
Esri Regular Contributor

Hi @LaoiseDillon 

The image-map appearance is not supported in the Survey123 web app. Please see documentation on image-map here and here, and also this blog post. You could raise this as an enhancement request with Esri Support, or up-vote this ArcGIS Idea and add your comments to it:

Select options of image-map to work in internet br... - Esri Community

Best, Jim

0 Kudos
LaoiseDillon
New Contributor

Hi Jim, thank you very much for your response.

Best,

Laoise

0 Kudos