Survey123 Updated Form Will Not Publish

7675
30
Jump to solution
04-16-2018 05:57 AM
JoshHabel
Occasional Contributor

Hello,

I am having an issue updating an existing survey.  Below are the 3 items I changed.  Not sure why it is not publishing.  I have not added any new fields or choices.  Hoping that someone can shed some light on this.  I just finished creating several maps, apps, and a dashboard the pulls from this forms feature service and I would hate to have to recreate all of that to make these simple changes.  I have attached both the working form and the modified form that won't publish.

1)   I  added back a pull data calculation to the "Inspected_By" field that I had previously deleted and also made it required. 

2)   I changed part of the calculation for the "maximum" field.

3) Changed case of 'OK' to 'Ok' in calculation for "Inspection_Priority" field.

Any ideas as to what the issue is would be very much appreciated!

Thanks,

Josh

1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Thanks Josh,

To diagnose further, there are 2 approaches:

1.  If you could start a log file to record the publishing process, the specific error can be determined.  See Troubleshoot—Survey123 for ArcGIS | ArcGIS and turn on logging (you can do so while the console list is still searching to log to a text file)

2. If you happen to know if anything has happened to the form item (i.e., it's been deleted, or moved folders/owners), that would likely be the cause.

View solution in original post

30 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Josh, 

I'm able to first publish your current working form and then update it with the new form with no issues.  What error message are you receiving when attempting to republish?

0 Kudos
JoshHabel
Occasional Contributor

James,

It's actually not given me an error yet.  The longest I've let it go is about 15 minutes.  It just sits there and churns and never finishes.  I'm going to try it again for at least an hour and see if it will eventually give me an error.  

Josh

0 Kudos
JoshHabel
Occasional Contributor

I've now let it run for about 2 hours and it has not finished or given me an error.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Thanks Josh,

From your description, it sounds as if there's an uncaught error in the publishing process.  At what step is this occurring (what is the last message displayed by the publishing screen)?

0 Kudos
JoshHabel
Occasional Contributor

The hangs up at the Updating survey form package.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Thanks Josh,

To diagnose further, there are 2 approaches:

1.  If you could start a log file to record the publishing process, the specific error can be determined.  See Troubleshoot—Survey123 for ArcGIS | ArcGIS and turn on logging (you can do so while the console list is still searching to log to a text file)

2. If you happen to know if anything has happened to the form item (i.e., it's been deleted, or moved folders/owners), that would likely be the cause.

JoshHabel
Occasional Contributor

I'm thinking i did move the form and service to a different folder.  Looking at my content it looks like i moved it from the folder that was automatically generated when i originally published it.  Attached is the error log which seems to verify this.  

0 Kudos
ThomasKukitz
New Contributor

I think you are absolutely correct. I moved mine and deleted the original folder and now it won't publish. So what is the solution for this? I can't remember the name of the old folder or I would recreate it. I did this once before, forgetting that if I move it I won't publish. When I moved it back it worked again. But now I am a bit screwed because I deleted the original folder.

0 Kudos
ThomasKukitz
New Contributor

I know this is an old post but, anyway, I somehow deleted my service definition when I moved the form to another folder. So to fix it I opened Survey123 Connect and downloaded the form, of course it reverted back, but then I made the changes again and then it published. I hope this helps someone.

 

0 Kudos