Survey123 Repeats Blank when editing from Inbox even with query allowUpdates=True

08-09-2022 12:37 PM
New Contributor III


I have a private complex survey that has evolved over time for last 4 years as features become available.  This survey has several separate Repeats sections (one for Samples, one for Results etc).  When editing from the inbox the Samples Repeats works fine to allow editing but Results Repeat continually shows up with Blank records everytime I go in to edit regardless of changes I have made.  I have set bind::esri:parameters = query allowUpdates=true.  I have also tried bind::esri:parameters = query allowUpdates=True. I have also tried  copying/pasting parameters from working Samples Repeat.




Inbox has a query on it to filter surveys in the last year recordDate>='2021-01-01' as  survey has been loaded with with over10 years of  backdated data and 6000+ records in the original.  so some fixes are bandaids to prevent reloading and relinking all the repeat sections.

I am working with Survey123 Connect Version 3.14.261, on AGOL.  The Survey is being Used on Desktop (Windows) and iPads.  Survey123 Field App version 3.14.242 for windows, and iPad Survey123 App version 3.15.146.


xlsx attached Results section is from lines 258 - 304.  I also push summaries of the repeats into the main survey.


1 Reply
New Contributor II


I have observed the same strange behavior. In my form, blanks appear in only one of the repeats. The data is clearly present in the database but is not transferred into the inbox form. The blanks always appear in the same questions which are all located in the first repeat. The subsequent repeats have no blanks (all the data is transferred).


What’s going on? Any ideas?

0 Kudos