Survey123 Inbox not showing all data in fields

07-31-2022 03:14 PM
New Contributor III

We have a small, simple Survey123 survey that I need to update when Corrective Auction Requests are completed.  To do this I am using the inbox function so I can edit the fields.

A problem has arisen where some of the data isn't displaying when you view the form.  The data is there as I can see it when I view the survey data via the Survey123 website.  I can add more data to the field and its updated, however, the data can't be viewed using the inbox.

Annoyingly, the missing data isn't constant between forms.

1) all forms are missing the same field called CAR details


2) some forms have missing fields which vary between survey forms

The only consistent things is that always a text field.

I have looked at the xml file and I can't see anything obvious. The fields all have the same setting -text - multi line - fieldlength of 1000 which is standard across forms I have designed.

If you view the form through ArcGis Survey123 website you can't see the field. However if you go to edit the survey form in the website, you can see the field. Not sure if this is a problem or not.  I have never noticed this before.

This form was working before the 3.14 app update.  All entries and edits are done using a PC - not using the Survey123 app.





0 Kudos
4 Replies
Esri Regular Contributor

Hello @BrentRogan

There was a significant change in how calculations are managed with the 3.14 Survey123 update. Are you using the latest version of the Survey123 field app 3.15.151? If so do the fields experiencing the issue have relevancy set on them or are in a repeat? If possible would we be able to obtain a copy of an XLSForm experiencing the behavior to reproduce on our end? 

Thank you,
0 Kudos
New Contributor III

Morning Zach

I got an answer yesterday from the New Zealand ESRI rep that solved the problem. 

The field was part of a repeat, so from my understanding the data was being saved, however it wasn't being pulled back into the field when you viewed it.

We solved it by setting esri::ersi:parameters to query allowupdates=true

Thanks for getting back to me

0 Kudos
New Contributor III

Hi Brent,


I'm having the same issue with a few questions in a survey that have both relevant and required column calculations to display them based on a preceding question. Did you put "allowupdates=true" in the "parameters" or "bind::esri:parameters" column in Survey123 connect to fix the issue? 

0 Kudos
New Contributor III

"query allowUpdates=true" is in the column headed bind::esri:parameters

The problem was that the repeat wasn't updating.  Below is an image of the repeat structure


Hope this helps

0 Kudos