Survey123, how do you find out what error codes mean? My survey is "Unable to preview survey". I don't have a clue what the details are telling me in order to correct it.

952
5
07-07-2020 01:14 PM
VaLoyBriscoe
New Contributor

URIError: URI malformed at decodeURIComponent () at _setSurveyRow (/home/ec2-user/libs/survey123-formConverter/dist/modules/json2xls.js:1:11234) at r.questions.forEach (/home/ec2-user/libs/survey123-formConverter/dist/modules/json2xls.js:1:3547) at Array.forEach () at Promise.resolve.then.then.then.then.e (/home/ec2-user/libs/survey123-formConverter/dist/modules/json2xls.js:1:3082) at tryCatcher (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/util.js:16:23) at Promise._settlePromiseFromHandler (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/promise.js:547:31) at Promise._settlePromise (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/promise.js:604:18) at Promise._settlePromise0 (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/promise.js:649:10) at Promise._settlePromises (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/promise.js:729:18) at _drainQueueStep (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/async.js:93:12) at _drainQueue (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/async.js:86:9) at Async._drainQueues (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/async.js:102:5) at Immediate.Async.drainQueues [as _onImmediate] (/home/ec2-user/libs/survey123-formConverter/node_modules/bluebird/js/release/async.js:15:14) at runCallback (timers.js:763:18) at tryOnImmediate (timers.js:734:5)

Tags (3)
0 Kudos
5 Replies
DanielWalsh
New Contributor II

I had the same issue and was able to get around it by removing the % character in my questions, specifically the hint. Not sure why but that did the trick for me.Hope it helps!

by Anonymous User
Not applicable

Can confirm this works.

Just went through 31 "%"'s on my survey and changed them to "percent" and low and behold, that fixed it. Thanks for the heads up.

ESRI needs to check their javascript, this is a big issue.

MoonLe
by
New Contributor

Hi, 

Today, I face the same issue, it keeps showing a string of error which I tried to create a copy, change time, but I still fail :(. May you guys help! 

0 Kudos
SierenErnst
New Contributor

I am also having this problem.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi @MoonLe , @SierenErnst ,

Addressing these issues is best addressed by opening a support ticket with Esri support.

0 Kudos