Select to view content in your preferred language

Survey123 feature service Table not accessible in Map Viewer layer options

1643
13
Jump to solution
05-16-2023 01:28 AM
ChristopherCounsell
MVP Regular Contributor

Key details:

  • Survey123 Connect 3.17.55
  • Publish new survey form with a point layer and repeat (no geometry in the repeat). Have tested multiple surveys and devices. No keywords or shenanigans.
  • Add created feature layer to Map Viewer
  • Click layer options... no 'table' option for the point layer
  • Click 'show related records' in the item overview data page and it returns 'Data Error'
  • The table appears:
    • In Map Viewer Classic
    • In the Map Viewer pop-up
    • For the related table (no geometry)
    • In a View layer of the same service, in Map Viewer

Is this a known issue? Bit concerning if the new Map Viewer isn't friendly with simple surveys or there's something else going on with the tables created by survey

dataError.PNGnoTable.PNG

 

0 Kudos
1 Solution

Accepted Solutions
ChristopherCounsell
MVP Regular Contributor

BUG-000158590 if anyone wants to contact esri support and be attached to it.

View solution in original post

0 Kudos
13 Replies
JoshuaSharp-Heward
Occasional Contributor III

Is it shown in the "tables" section of the new map viewer? Standalone and related tables are located here:

JoshuaSharpHeward_0-1684229448816.png

In the new map viewer.

 

ChristopherCounsell
MVP Regular Contributor

Thanks @JoshuaSharp-Heward. No it's not visible there. It's not a standalone or related table as it has point geometry. The related table from the repeat is.

Creating a view layer, the table appears as an option on the parent geometry layer.

Looking like a potential defect just finding it difficult to confirm expected behaviour with the new Map Viewer.

0 Kudos
JoshuaSharp-Heward
Occasional Contributor III

Ah apologies, re-reading I can see I misinterpreted what you were saying!

DougBrowning
MVP Esteemed Contributor

Not sure I get your issues but The new map viewer has no related recrods button at all and it does not have the reltated records in the attribute table either so you will probably want to stick with the Classic map viewer anyway.  I am sticking with classic for 1-2 more years becuase of that lack of related record support also.  Been meeting with Esri on it but no luck so far.

Have you adjusted all the security type settings on both the service and from the 123 website?  It may be set to not allow viewing of recrods.

ChristopherCounsell
MVP Regular Contributor

I'm the admin and owner of the feature service. Adding to a new Web Map. The table option is not available for the point layer in the service. The related table is (under tables, not layers). Hosted Feature Layers not created through Survey123 are fine. A hosted feature layer view of the same problematic layer has the table option.

Simply put, a feature service created with Survey123 doesn't give the option to open the attribute table from the layer in Map Viewer.

Looking like a defect... 

0 Kudos
JoshuaSharp-Heward
Occasional Contributor III

I checked at work today and I found the exact same behaviour for a hosted feature service created by Survey123 - so definitely seems to be a defect.

ChristopherCounsell
MVP Regular Contributor

have a support case who reproduced it. Will share a bug number when I get one

0 Kudos
ChristopherCounsell
MVP Regular Contributor

BUG-000158590 if anyone wants to contact esri support and be attached to it.

0 Kudos
SamPociask
New Contributor II

I searched for this bug and nothing comes up, did you ever get any answers to this?

0 Kudos