Survey123: Failed to Save - cannot read property 'success' of undefined

1079
5
03-11-2020 10:06 AM
DrewThompson
New Contributor III

Hi there,

I'm experiencing an issue with an error code I'm receiving whenever I attempt to save new permissions for my surveys. I get the following error code: "Failed to save. Cannot read property 'success' of undefined".

Ultimately, when we back out of this page and navigate back to the My Surveys view, the new permissions are saving - so it's not stopping us up. However, we have multiple people creating surveys this way and it's making people a little nervous that the guys in the field aren't going to be able to access the surveys.

Is there any way to remedy this?

5 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Drew,

Are the problematic surveys published from Connect or Survey123 website?

We recently fixed some Survey web app issues and you could try to force the survey using the latest version by going to survey123 website>Settings>Version>choose "Always use the latest version".

If it's possible, try to republish the survey again to see if that makes a difference.

Thanks,

0 Kudos
DrewThompson
New Contributor III

Hi Shwu-jing Jeng,

Thank you for responding. I navigated to the Settings>Version and the option for "Always use the latest version" was already selected. I tried re-publishing the survey and I am still receiving a similar error message when I attempt to save the collaboration settings. Do you have any other recommendations for how to fix this issue?

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Drew,

Could you go to your organization site and click my content to check the fieldworker view to see if the setting you tried to make did save when you received the error?

See the comment on this post for reference:

https://community.esri.com/thread/239946-cannot-read-property-success-of-undefined 

Is the survey and feature service hosted on portal or AGOL?

0 Kudos
GilbertTayebwa
New Contributor

I managed to solve the issue by clearing the browser cache data in the browser (your firefox or google chrome)

Kenzha
by
New Contributor

I cleared the browser cache data and I was abble to publish my survey, thanks

0 Kudos