Select to view content in your preferred language

Survey123 App Crashing when opening a geopoint question offline

734
6
05-03-2023 01:00 PM
AlexandraLehner
New Contributor II

Hello, 

I have a survey that multiple people have been using offline. I have a set of repeat questions, one of which is a geopoint question. Basically, I have it set up so if you see a particular bird species more than once during a survey, can add sightings, entering in a location via the geopoint each time. I have used this function fine mutliple times. This morning, and now this afternoon, the app crashes whenever I try to even open the geopoint question. I have no idea what would have gone wrong here, considering that it worked before. 

I did clear the app's cache, tried restarting. Any thoughts?

0 Kudos
6 Replies
IsmaelChivite
Esri Notable Contributor

Can you please share your XLSForm?

We would need to test your survey design and try to reproduce the crash. What device are you using?

AlexandraLehner
New Contributor II

It is a Galaxy XCover Pro, but it also happens on my Galaxy Tab Active 2. 

0 Kudos
AlexandraLehner
New Contributor II

Absolutely, it should be attached now. 

0 Kudos
Marie-AngeFournier-Beck
New Contributor III

@AlexandraLehner  did you resolve this issue? I am having a similar problem, except it isn't related to a repeat question. I have one geopoint question and several linked maps (mobile map packges) on my device (Android). Every time I go to answer the geopoint question, whether in cell service/wifi or not, it crashes. Any tips on what you were able to sort out are great appreciated.

0 Kudos
AlexandraLehner
New Contributor II

No, I never did. This is an early spring survey, so I haven't needed to use it since then. I will need to address it before next spring though (or just make a whole new survey). 

0 Kudos
AlexandraLehner
New Contributor II

Although now I wonder if the problem is more related to the offline map than to the repeats.