Sign in to ArcGIS Online with Survey123 OAuth2 error

2944
14
04-03-2017 05:43 AM
imbGISTeam
New Contributor II

I'm having issues with Active Directory users attempting to sign in to ArcGIS Online with Survey 123 (no such errors with Collector) and the issue does not apply to all users. Some users are getting the following message:

"Please copy this code, switch to your application and paste it there:"

OAuth2 Approval

Any suggestions?

Tags (2)
0 Kudos
14 Replies
JoeWeyl
Occasional Contributor

James -

That won't work with our Portal. There is an issue with the redirect script at 10.4 if you are not using the Web Adaptor, that you guys fixed at newer versions, we just haven't been able to upgrade yet, that is why Jim is getting the login redirect URL error.

Joe

0 Kudos
JimHerberich
New Contributor II

As I showed in my post we tried that, but the external browser opens to a bad URL.  Our Portal is 10.4

MegHoole
Occasional Contributor III

Hi James - we recently used your workaround with our enterprise enabled AGO accounts.  Sign in issues were noted on an iPad and iPhone using our ArcGIS Online enterprise sign-in enabled accounts.  We're not using Portal for ArcGIS Online - but had to use the the workaround.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Meg,

We believe that we have addressed the issue for 3.2; if you go into the Early Adopter Community, you can access the a build via Apple TestFlight that should work.

0 Kudos
FieldUser1One
New Contributor III

Hi James,

I'm seeing this in 3.13.239.  This is popping up about the same time some surveys being limited in:

- Concatenation Length and

- Undefined Operation rollback Error.

FieldUser1One_0-1638208407431.png

FieldUser1One_1-1638208456514.png

FieldUser1One_2-1638208484975.png

FieldUser1One_3-1638208511972.png

 

 

 

 

0 Kudos