Shared Tile Package does not appear as Survey Link Option

07-09-2020 10:15 AM
Occasional Contributor II

Hi all,

I have created a couple of map tile packages for use as offline basemaps to collect polygons in several Survey123 surveys. I used this document for my process: Prepare basemaps for offline use—Survey123 for ArcGIS | Documentation 

I have uploaded the .tpk files to ArcGIS Online and have shared them as well. However, when attempting to 'Add Map Link' to the Survey in Survey123Connect, the new tile packages do not appear in the list as options to link.

I am aware that I can include the maps through other methods, either by copying them into the survey123 Maps folder or editing the .info, file. But the Add map Link option would be the simplest way at the moment, and I don't want to move on without exhausting that possibility.

Do I need to publish the tile package as a hosted service or incorporate the tiles into a Web Map first? The Instructions do not mention having to do that. Please let me know if there is anything I might try to resolve this.

0 Kudos
4 Replies
by Anonymous User
Not applicable

Hi Henry,

Are you still having this issue or were you able to resolve it? What version of of Survey123 Connect were you using?

In the upcoming 3.10 release, we have improved support for Linked Content and made a few other changes. Can you please test out the latest 3.10 RC builds available on the Early Adopter Community.

It could be possible that the tpk you are using has an unsupported spatial reference? Do you know what spatial reference the tpk is? There is a new option in the filter for Linked Content in Connect to ignore the spatial reference. Whilst this help display the items that have an unsupported spatial reference, if you select the item it may not display in the field app.

Also yes, can you also test publishing it as a hosted service?



0 Kudos
Occasional Contributor II

Hi Phil,

I was using Survey123 Connect version 3.9.120. We actually managed to work around the issue by instead exporting the raster extent that we wanted available offline as a Tile Cache, using the Export to Tile Cache tool instead of a Tile Package as the documentation I read instructs. The tile cache showed up as linked content and it has been associated with the surveys and is available in the field.

I used the WGS 1984 Web Mercator Auxiliary Sphere for the image, so I don't believe it was a spatial reference issue, but I can try the filter to ignore spatial reference in the future.

I'll take a look at the 3.10 release, good to know a new version is on the way!

New Contributor II

I had the same issue. Are you sure you created a "tpk" and not the default "tpkx"? 

Short story: I had tile packages created in an older version of ArcMap. I did a big upgrade and switched to enterprise portal. My old map packages worked fine, the new one I created didn't. So I created one as the old version 'tpk' and one as 'tpkx'. The tpk worked with no problem. 

I hope this proves useful. If you need me to clarify anything, please let me know. 

0 Kudos
New Contributor III

Not sure about why this happens, but I am now assuming it has to do with the file size: 

The documentation mentions it:  Prepare basemaps for offline use—Survey123 for ArcGIS | Documentation 


I am having the same issue so frustrating!! Anyways hope this helps someone

0 Kudos