select_one_from_file does not display correct choices, instead displays all choices as 'label'

959
4
05-03-2022 11:25 AM
Brice_Allen
New Contributor

I am creating a Survey123 app that I would like to use select_one_from_file on a csv. The csv is located within the media folder. In the 'type' column in the xlsx form I have it as follows:

select_one_from_file numbers.csv

Within the numbers.csv file there is a field named project_numbers, then there are 3 project numbers listed below that of unique values. When I save and load up the app I get the results below. Rather than the unique numbers being shown it will display 'label' for each number in that csv file. What more do I have to do with select_one_from_file to allow it to display correctly? Do I have to specify the field somewhere? 

Brice_Allen_0-1651602236747.png

 

0 Kudos
4 Replies
IsmaelChivite
Esri Notable Contributor

I think your CSV file could be missing the 'label' column. More details here: https://community.esri.com/t5/arcgis-survey123-blog/survey123-tricks-of-the-trade-external-choice/ba...

IsmaelChivite_0-1651610781260.png

 

0 Kudos
MonicaRuano1
New Contributor II

Hi, 

I'm having the same problem also when using the "select_one_from_file". I have copied the csv in to the media folder. The csv has just two columns "name" and "label".  My csv file is called artslistesnohvit.csv

If I copy the list in the "choices" sheet It works but If I just want to use the external choices list, it doesn't work.  

I am attaching how the csv file looks like, it is around 3000 rows. And how my survey looks when using Select_one_from_file artslistesnohvit.csv 

What could I be doing wrong?

Thanks for the help,

Monica

 

 

 

0 Kudos
MauricioBetancourtGonzález
New Contributor

Hi, someone has solved the problem?

MonicaRuano1
New Contributor II

Hi @MauricioBetancourtGonzález ,

I managed to fix the problem by opening the csv file using for example "Notepad" and checked which column separation is being used. I found that the file was using ";" instead of ",". If this is your case then you can just use the Search and Replace function to replace all the ";" with "," and save again. 

This worked for me.

0 Kudos