Publishing Error - Code 500 - Dataset not found

6776
12
10-31-2018 02:17 PM
AlexandrePrado
New Contributor

Hello!

 

So I have been trying to publish a form (attached below) that I created in Survey123 Connect to our ArcGIS Portal, but show me this error code 500: Dataset not found. I don´t know why!!! 

I have attached the excel spreadsheet as well.

Any help would be most appreciated.

0 Kudos
12 Replies
EricAnderson_DHS
Occasional Contributor

Hey @Henry ,

 

Yeah "current_date" was just a particular reserved field name that we were using, but there's obviously a lot more than that. If you're using the latest version of Survey123 Connect there should be a sheet in there with the list of reserved field names, and if you're savvy enough with Excel, you can probably do some type of lookup function. 

It's funny you bring this up because I just published a new survey earlier this week with the field name "current_date" (guess i completely forgot about this post) and it automatically changed it to "_current_date". This was publishing from Connect v. 3.11.123 to Portal 10.8.1. 

AndrewSouthern
Occasional Contributor

EricA,

Thank you for this advise as it helped lead me to my problem.  I wasn't using a reserved word for a field name, but noticed that I had used the same name for multiple note fields.  XLS didn't flag the error, and I don't often use notes in survey designs, so I didn't realize that notes style "questions" are included in the table schema and therefore must follow the same rules as far as not being duplicated.  I have attached a screen grab of the XLS that shows the two note fields with same names not flagged red, and two other question types with same name that are flagged as red as a comparison.

Thanks again.

EricAnderson_DHS
Occasional Contributor

Thanks @AndrewSouthern ! My team just hit this 500 "Dataset not found" error again in Survey123 Connect 3.13.251 and your comment saved us. There were duplicate field names in the survey form.

 

@JamesTedrick  - Is the product team still planning on fixing this error?? Or make the error more descriptive to the actual issue. 

0 Kudos