pulldata() no longer working

486
1
02-02-2022 07:10 AM
RachelHackett
New Contributor III

The pulldata() function is no longer working to retrieve values from a .csv in the media folder for my Survey123 form. I have tried half-a-dozen things with no luck.

This newer survey (2022) was made from an older survey (published early 2021) where the pulldata() worked in Survey123 at the time. Now on the older survey the pulldata() continues to work on the form on the field app, but no longer functions/displays on the Survey123 Connect preview. Neither work on the new survey.

Attached is the newer survey XLSForm (rows/lines 48-61) and .csv file used for pulldata().

Using Survey123Connect version 3.13.239; form version 3.12.

Edit: Added .zip file of entire survey to previous .xlsx and .csv attachments.

1 Reply
RachelHackett
New Contributor III

A few things I've tried:

  • Double-checked names
  • Give all fields display names
  • Resaved .csv file
  • Made .csv filename shorter
  • Replaced ";" with "," (changed back to ";" after it didn't work)
  • Moved fields out of the repeat
0 Kudos