Published Survey wont stay published

380
3
03-02-2023 07:43 AM
AliceWilson
New Contributor III

I created a survey 123 using the web design vs connect. Didn't make changes to it though I did move it to a new folder in mu content someone said that may be an issue though it worked fine after that. Worked yesterday morning on one pc where I demoed it to a group to get them to start using. They requested a few changes went to edit the form and had not made any changes yet - in the design panel it requested I save and publish to save changes - did so and get save/published successfully, yet when I look it is asking me to publish again - and the survey works off/on sometime getting a 400 error and when I go to edit collaboration piece it wont allow to save without publishing changes when there are no and I have published many times. Finally get folks to use the survey then it wont work.

0 Kudos
3 Replies
IsmaelChivite
Esri Notable Contributor
0 Kudos
AliceWilson
New Contributor III
0 Kudos
AliceWilson
New Contributor III

From my ESRI TEch 

I've performed testing from my end and was able to reproduce the issue. It seems like the issue can happen if either map or multiple-choice question is included in the survey. Here are the details of the bug for your reference: 

  • Bug Number: BUG-000154641
  • Synopsis: The ArcGIS Survey123 web app does not recognize when changes are saved and published after modifying a survey with a multiple-choice question.
  • Status: Under Consideration
  • Bug Number: BUG-000154545
  • Synopsis: Notification that "survey has changes that have not been published yet" appears despite the fact that survey was not edited if Map question is included in Survey123 ArcGIS Online web
  • Status: In Product Plan

The bug will now be reviewed by our development team and further action will be taken to address this issue. I have attached the bug to this case as well, which you now should be able to see its full description in:

  • My Esri > My Organization > Support > Search for the BUG-000154641 and BUG-000154545
0 Kudos