Public Survey123 Form prompts Login

434
2
05-16-2023 10:05 AM
MANESK
by
Occasional Contributor

HI..
I'm using Survey 123 Connect desktop app (version 3.17.55) from Arcgis Enterprise Portal to build a survey form.

I have shared the survey form, feature layer with everyone (public) to access it without any credentials.

The survey form from the Mobile app(survey123) is possible to access without any credentials .

The issue is that it prompts to login  when the survey link url is accessed through webbrowser

link of the url is in the below format

https://survey123.arcgis.com/share/<surveyitem id>?portalUrl=https://<portalname>/<webadaptor>

After clicking cancel, the login window disappears and i'm able to feed the input parameters in the form.

How to avoid the display of login window, even after sharing the access to everyone? It looks so messy and confused where i'm going wrong

Request to provide a workaround for this issue.

Thanks in advance.

0 Kudos
2 Replies
DavidPike
MVP Frequent Contributor

https://enterprise.arcgis.com/en/portal/latest/administer/linux/configure-security.htm

Allow anonymous access to your portal—Enable this option to allow anonymous users access to your organization's website. If this option is not enabled, anonymous access is disabled, and anonymous users cannot access the website. They also cannot view your maps with Bing Maps (if your organization is configured for Bing Maps).

0 Kudos
MANESK
by
Occasional Contributor

Thanks David for your reply...

I tried the above mentioned workaround  and even republished the survey ,but still it persists. Any clue ,why still it prompts !

0 Kudos